z/OS Tools & Language

Expand all | Collapse all

R execution error

  • 1.  R execution error

    Posted 09-03-2017 20:22

    Hello,
    I installed R V3.3.2 on z/OS V2.1

    stderr on USS(teraterm)

        > R
        [1] + Done(137) R
        50332419     Killed /u/XXX/YYY/R332/bin/R
    

    syslog messages

    BPXP018I THREAD 562D460000000001, IN PROCESS 50332419, ENDED 203
    WITHOUT BEING UNDUBBED WITH COMPLETION CODE 04000FFD
    , AND REASON CODE 00000224.
    

    I tried “R --verbose” command, but it failed with same error without additional information.

    BPXP018I
    https://www.ibm.com/support/knowledgecenter/ja/SSLTBW_2.1.0/com.ibm.zos.v2r1.ieam300/dp0817s.htm

    According to the description, it seems that the above completion code indicates user completion code.

    I set the following environment to the shell on which I invoked “R” command.

    # for python-devel
    export _BPXK_AUTOCVT=ON
    export BD=/u/XXX/YYY/python
    export PATH=$BD/bin:$PATH
    export LIBPATH=$BD/lib:$LIBPATH
    export PKG_CONFIG_PATH=$BD/lib/pkgconfig:$BD/share/pkgconfig
    export CURL_CA_BUNDLE=$BD/etc/ssl/cacert.pem
    export FFI_LIB=$BD/lib/ffi
    export X11_DIST=$BD
    export DEVEL_DIST=$BD
    
    # for R332
    export BASE=/u/XXX/YYY/R332
    export PATH=$BASE/bin:$PATH
    export LIBPATH=$BASE/lib:$LIBPATH
    export PKG_CONFIG_PATH=$BASE/lib/pkgconfig:$PKG_CONFIG_PATH
    export TZDIR=$BASE/lib/R/share/zoneinfo
    export RHOME=$BASE/lib/R
    export R_DIST=$BASE
    

    Could you please advise me how to solve this issue?

    With best regards.
    Tomohiro Taguchi



  • 2.  RE: R execution error

    Posted 09-04-2017 01:36

    Sorry,
    I missed to paste one sentence.

    I installed R V3.3.2 on z/OS V2.1.
    After istallation, I tried to invoke “R” command but it failed with the following messages.

    stderr on USS (teraterm)

    > R
    [1] + Done(137) R
       50332419     Killed /u/XXX/YYY/R332/bin/R
    

    With best regards.
    Tomohiro Taguchi



  • 3.  RE: R execution error

    Posted 09-05-2017 15:07

    Hello,
    It looks like this issue will be easy to solve.

    I looked up abend U4093 reason 224, and I found this:
    https://www.ibm.com/support/knowledgecenter/en/SSLTBW_2.3.0/com.ibm.zos.v2r3.ceea900/cs00020.htm
    X’224’ (548)
    The 64-bit virtual limit (MEMLIMIT) was 0. This setting prevents the initialization and execution of an AMODE 64 application under Language Environment since storage above 2GB cannot be allocated. SMFPRMxx parameter MEMLIMIT, JCL JOB statement keyword MEMLIMIT, and JCL EXEC statement MEMLIMIT keyword are some of the mechanisms for setting the amount of 64-bit virtual storage that can be allocated in the address space. See z/OS MVS Programming: Extended Addressability Guide for more information on setting MEMLIMIT and how the system determines what value to use.

    Best regards,
    Rick Harris



  • 4.  RE: R execution error

    Posted 09-07-2017 02:52

    Thank you so much for your comment.
    I will try again after changing MEMLIMIT parameter.

    Thaks!:grin:
    Tomohiro Taguchi