z/OS Tools & Language

Expand all | Collapse all

R and Python 2.7

  • 1.  R and Python 2.7

    Posted 08-05-2020 06:03

    Just downloaded r-3.3.2_b0005.170107.tar.gz. The README mentions Python 2.7 which is unsupported now. So, Python 2.7 is no option.

    Question: Is R supposed to work with a Python 3.x version?


    Thanks, Manfred



  • 2.  RE: R and Python 2.7

    Posted 08-06-2020 06:45

    Hello ManfredLotz,

    R + Python 3.7 will be available with Miniconda shipping coming soon, stay tuned

    Thanks,
    Alexander



  • 3.  RE: R and Python 2.7

    Posted 08-06-2020 07:24

    Thanks Alex. I have already Python 3.6.1 installed. Could I point R to 3.6.1, or is this a bad idea?



  • 4.  RE: R and Python 2.7

    Posted 08-06-2020 07:33

    Not sure about R 3.3.2 version (never tried it). Miniconda will have R base 3.5.2 + more than 100 of R packages



  • 5.  RE: R and Python 2.7

    Posted 08-06-2020 07:34

    Aah, ok. Good to know that the R version in Miniconda is newer. So, I will ignore R 3.3.2.