z/OS Tools & Language

Expand all | Collapse all

Vim 8.0.22 for z/OS released

Yaroslav Kuzmin11-22-2017 06:00

  • 1.  Vim 8.0.22 for z/OS released

    Posted 07-06-2017 09:30

    Rocket is pleased to announce the pre-release of Vim 8.0.22 for z/OS. This port has been in use for a couple of months internally at Rocket by our developers, however we have not had time to run a full QA suite. Thus this is not considered GA quality.

    Please go to the Rocket Community Portal for download.

    -Peter



  • 2.  RE: Vim 8.0.22 for z/OS released

    Posted 08-04-2017 03:09

    I can’t seem to get syntax highlighting or any color at all. Are colors not supported in this port?



  • 3.  RE: Vim 8.0.22 for z/OS released

    Posted 08-04-2017 07:46

    Please try this:

    Within VIM
    :echo $MYVIMRC
    :echo $VIMRUNTIME
    and check set up tag in directory $VIMRUNTIME and check set up environment variables _BPXK_AUTOCVT _CEE_RUNOPTS and check configure TERMINFO and XTERM

    *** Rocket internal tracking reference: USSP-837 ***



  • 4.  RE: Vim 8.0.22 for z/OS released

    Posted 08-25-2017 02:59

    My settings are all good. Syntax highlighting is kind of working but not in color. The syntax files are read ok and keywords are highlighted but only in black and white. I’ve been using git and node.js with colors no problem.



  • 5.  RE: Vim 8.0.22 for z/OS released

    Posted 08-25-2017 08:31

    This is likely an issue with TERMCAP/TERMINFO (an area of Unix I’ve always found somewhat mysterious…). I will check with another developer her who knows more about this.



  • 6.  RE: Vim 8.0.22 for z/OS released

    Posted 11-20-2017 07:52

    Did you ever get any feedback on this. I would love to have color using Vim on z/OS.



  • 7.  RE: Vim 8.0.22 for z/OS released

    Posted 11-20-2017 10:12

    The vim on z/OS supports the color correctly.
    Need to configure TERMINFO system.

    To check the TERMINFO system, use the command

    printf “\e[32m\e[44mtest\e[0m\n”



  • 8.  RE: Vim 8.0.22 for z/OS released

    Posted 11-21-2017 00:04

    Thanks Yaroslav. I tried the command you posted and it worked fine. But Vim doesn’t have colors.



  • 9.  RE: Vim 8.0.22 for z/OS released

    Posted 11-21-2017 01:40

    What color scheme and how do you install it in the vim?

    What the infocmp command displays ?



  • 10.  RE: Vim 8.0.22 for z/OS released

    Posted 11-21-2017 02:31

    I’m using the elflord colorscheme. All the colorschemes are already installed in /usr/local/share/vim/vim80/colors. VIMRUNTIME is set in my .profile export VIM=/usr/local/share/vim/vim80.

    DOC:/u/bamboo/txc/txcdemo1/conf: >infocmp
    #       Reconstructed via infocmp from file: /usr/share/lib/terminfo/x/xterm
    xterm|vs100|xterm terminal emulator,
            am, km, msgr, xenl,
            cols#80, it#8, lines#25,
            batt1=f1, batt2=f1md, bel=^G, blink=@, bold=\E[1m,
            box1=lqkxjmwuvtn, box2=lqkxjmwuvtn, civis=\E[?25l,
            clear=\E[H\E[2J, cnorm=\E[?25h, cr=\r,
            csr=\E[%i%p1%d;%p2%dr, cub=\E[%p1%dD, cub1=\b,
            cud=\E[%p1%dB, cud1=\n, cuf=\E[%p1%dC, cuf1=\E[C,
            cup=\E[%i%p1%d;%p2%dH, cuu=\E[%p1%dA, cuu1=\E[A,
            cvvis=\E[?25h, dch=\E[%p1%dP, dch1=\E[P, dl=\E[%p1%dM,
            dl1=\E[M, ed=\E[J, el=\E[K, font0=\E(B, font1=\E(0,
            home=\E[H, ht=\t, hts=\EH, ich=\E[%p1%d@, ich1=\E[@,
            il=\E[%p1%dL, il1=\E[L, ind=\n, kbs=\b, kcub1=\E[D,
            kcud1=\E[B, kcuf1=\E[C, kcuu1=\E[A, kf1=\E[11~,
            kf2=\E[12~, kf3=\E[13~, kf4=\E[14~, khome=\E[H,
            kich1=\E[2~, knl=\r, ktab=\t, mc4=\E[4i, mc5=\E[5i,
            rc=\E8, rev=\E[7m, ri=\EM, rmcup=\E[?7h, rmkx=\E>,
            rmso=\E[m,
            rs1=\E>\E[1;3;4;5;6l\E[?7h\E[m\E[r\E[2J\E[H, rs2=@,
            sc=\E7,
            sgr=\E[%?%p1%t;7%;%?%p2%t;4%;%?%p3%t;7%;%?%p4%t;5%;%?%p6%t;1%;m%?%p9%t\E(0%e\E(B%;,
            sgr0=\E[m, smcup=\E[?7h\E[?1l\E(B\E=, smkx=\E=,
            smso=\E[7m, tbc=\E[3g,


  • 11.  RE: Vim 8.0.22 for z/OS released

    Posted 11-21-2017 03:00

    So , not a complete TERMINFO database
    Update the database using the xterm_zos.gz (1.2 KB)
    database file and the following commands

    export TERM=xterm_zos
    export TERMINFO=< your directory >
    gzip -d xterm_zos.gz
    tic xterm_zos

    Such a color scheme exists



  • 12.  RE: Vim 8.0.22 for z/OS released

    Posted 11-21-2017 03:18

    Getting closer but not there yet. I think I followed your instructions correctly but maybe I made a mistake.

    DOC:/u/doc/terminfo: >env | grep TERM
    TERM=xterm_zos
    TERMINFO=/u/doc/terminfo
    DOC:/u/doc/terminfo: >ll
    total 80
    drwxrwxr-x    3 DOC      INTERNAL    8192 Nov 21 15:11 .
    drwxrwxr-x  162 DOC      INTERNAL   16384 Nov 21 15:14 ..
    drwxr-xr-x    2 DOC      INTERNAL    8192 Nov 21 15:07 x
    -rw-rw-r--    1 DOC      INTERNAL    2778 Nov 21 15:05 xterm_zos
    DOC:/u/doc/terminfo: >find .
    .
    ./xterm_zos
    ./x
    ./x/xterm
    DOC:/u/doc/terminfo: >infocmp
    Error: Term "xterm_zos" not found in /usr/share/lib/terminfo or /u/doc/terminfo
    ,
            bitwin#0, bitype#0, btns#0, bufsz#0, colors#0,
            cols#0, cps#0, it#0, lh#0, lines#0, lm#0, lw#0, ma#0,
            maddr#0, mcs#0, mjump#0, mls#0, ncv#0, nlab#0,
            npins#0, orc#0, orhi#0, orl#0, orvi#0, pairs#0, pb#0,
            spinh#0, spinv#0, vt#0, widcs#0, wnum#0, wsl#0,
            xmc#0,
    DOC:/u/doc/terminfo: >cat xterm_zos
    #       Reconstructed via infocmp from file: /u/pdkuzm/local/share/terminfo/x/xterm
    xterm|xterm terminal emulator (X Window System),
            am, bce, km, mc5i, mir, msgr, npc, xenl,
            colors#8, cols#80, it#8, lines#24, pairs#64,
            acsc=``aaffggiijjkkllmmnnooppqqrrssttuuvvwwxxyyzz{{||}}~~,
            bel=^G, blink=\E[5m, bold=\E[1m, cbt=\E[Z,
            civis=\E[?25l, clear=\E[H\E[2J, cnorm=\E[?12l\E[?25h,
            cr=\r, csr=\E[%i%p1%d;%p2%dr, cub=\E[%p1%dD, cub1=\b,
            cud=\E[%p1%dB, cud1=\n, cuf=\E[%p1%dC, cuf1=\E[C,
            cup=\E[%i%p1%d;%p2%dH, cuu=\E[%p1%dA, cuu1=\E[A,
            cvvis=\E[?12;25h, dch=\E[%p1%dP, dch1=\E[P,
            dl=\E[%p1%dM, dl1=\E[M, ech=\E[%p1%dX, ed=\E[J,
            el=\E[K, el1=\E[1K, flash=\E[?5h$<100/>\E[?5l,
            home=\E[H, hpa=\E[%i%p1%dG, ht=\t, hts=\EH,
            ich=\E[%p1%d@, il=\E[%p1%dL, il1=\E[L, ind=\n,
            indn=\E[%p1%dS, invis=\E[8m,
            is2=\E[!p\E[?3;4l\E[4l\E>, kbs=\b, kb2=\EOE,
            kcbt=\E[Z, kcub1=\EOD, kcud1=\EOB, kcuf1=\EOC,
            kcuu1=\EOA, kdch1=\E[3~, kend=\EOF, kent=\EOM,
            kf1=\EOP, kf10=\E[21~, kf11=\E[23~, kf12=\E[24~,
            kf13=\E[1;2P, kf14=\E[1;2Q, kf15=\E[1;2R,
            kf16=\E[1;2S, kf17=\E[15;2~, kf18=\E[17;2~,
            kf19=\E[18;2~, kf2=\EOQ, kf20=\E[19;2~, kf21=\E[20;2~,
            kf22=\E[21;2~, kf23=\E[23;2~, kf24=\E[24;2~,
            kf25=\E[1;5P, kf26=\E[1;5Q, kf27=\E[1;5R,
            kf28=\E[1;5S, kf29=\E[15;5~, kf3=\EOR, kf30=\E[17;5~,
            kf31=\E[18;5~, kf32=\E[19;5~, kf33=\E[20;5~,
            kf34=\E[21;5~, kf35=\E[23;5~, kf36=\E[24;5~,
            kf37=\E[1;6P, kf38=\E[1;6Q, kf39=\E[1;6R, kf4=\EOS,
            kf40=\E[1;6S, kf41=\E[15;6~, kf42=\E[17;6~,
            kf43=\E[18;6~, kf44=\E[19;6~, kf45=\E[20;6~,
            kf46=\E[21;6~, kf47=\E[23;6~, kf48=\E[24;6~,
            kf49=\E[1;3P, kf5=\E[15~, kf50=\E[1;3Q, kf51=\E[1;3R,
            kf52=\E[1;3S, kf53=\E[15;3~, kf54=\E[17;3~,
            kf55=\E[18;3~, kf56=\E[19;3~, kf57=\E[20;3~,
            kf58=\E[21;3~, kf59=\E[23;3~, kf6=\E[17~,
            kf60=\E[24;3~, kf61=\E[1;4P, kf62=\E[1;4Q,
            kf63=\E[1;4R, kf7=\E[18~, kf8=\E[19~, kf9=\E[20~,
            khome=\EOH, kich1=\E[2~, kind=\E[1;2B, kmous=\E[M,
            knp=\E[6~, kpp=\E[5~, kri=\E[1;2A, kDC=\E[3;2~,
            kEND=\E[1;2F, kHOM=\E[1;2H, kIC=\E[2;2~, kLFT=\E[1;2D,
            kNXT=\E[6;2~, kPRV=\E[5;2~, kRIT=\E[1;2C, mc0=\E[i,
            mc4=\E[4i, mc5=\E[5i, op=\E[39;49m, rc=\E8, rev=\E[7m,
            ri=\EM, rin=\E[%p1%dT, rmacs=\E(B, rmam=\E[?7l,
            rmcup=\E[?1049l, rmir=\E[4l, rmkx=\E[?1l\E>,
            rmm=\E[?1034l, rmso=\E[27m, rmul=\E[24m, rs1=\Ec,
            rs2=\E[!p\E[?3;4l\E[4l\E>, sc=\E7, setab=\E[4%p1%dm,
            setaf=\E[3%p1%dm,
            setb=\E[4%?%p1%{1}%=%t4%e%p1%{3}%=%t6%e%p1%{4}%=%t1%e%p1%{6}%=%t3%e%p1%d%;m,
            setf=\E[3%?%p1%{1}%=%t4%e%p1%{3}%=%t6%e%p1%{4}%=%t1%e%p1%{6}%=%t3%e%p1%d%;m,
            sgr=%?%p9%t\E(0%e\E(B%;\E[0%?%p6%t;1%;%?%p2%t;4%;%?%p1%p3%|%t;7%;%?%p4%t;5%;%?%p7%t;8%;m,
            sgr0=\E(B\E[m, smacs=\E(0, smam=\E[?7h,
            smcup=\E[?1049h, smir=\E[4h, smkx=\E[?1h\E=,
            smm=\E[?1034h, smso=\E[7m, smul=\E[4m, tbc=\E[3g,
            u6=\E[%i%d;%dR, u7=\E[6n, u8=\E[?1;2c, u9=\E[c,
            vpa=\E[%i%p1%dd,


  • 13.  RE: Vim 8.0.22 for z/OS released

    Posted 11-21-2017 03:22

    You need to update the database.
    the following command

    tic xterm_zos



  • 14.  RE: Vim 8.0.22 for z/OS released

    Posted 11-21-2017 03:31

    I did issue the tic command. FYI, the file in is ISO8859-1 so I issued chtag -tc ISO8859-1 xterm_zos.

    DOC:/u/doc/terminfo: >ls
    x xterm_zos
    DOC:/u/doc/terminfo: >tic xterm_zos
    DOC:/u/doc/terminfo: >infocmp
    Error: Term “xterm_zos” not found in /usr/share/lib/terminfo or /u/doc/terminfo
    ,
    bitwin#0, bitype#0, btns#0, bufsz#0, colors#0,
    cols#0, cps#0, it#0, lh#0, lines#0, lm#0, lw#0, ma#0,
    maddr#0, mcs#0, mjump#0, mls#0, ncv#0, nlab#0,
    npins#0, orc#0, orhi#0, orl#0, orvi#0, pairs#0, pb#0,
    spinh#0, spinv#0, vt#0, widcs#0, wnum#0, wsl#0,
    xmc#0,



  • 15.  RE: Vim 8.0.22 for z/OS released

    Posted 11-21-2017 03:39

    my mistake. the tic command removes “_” symbol
    correct command

    export TERM=xtermzos
    export TERMINFO=< your directory >
    gzip -d xterm_zos.gz
    tic xterm_zos



  • 16.  RE: Vim 8.0.22 for z/OS released

    Posted 11-21-2017 03:46

    It’s created a file called xterm. If I use that it loads the database correctly.

    DOC:/u/doc: >export TERMINFO=/u/doc/terminfo
    DOC:/u/doc: >export TERM=xterm
    DOC:/u/doc: >infocmp
    #       Reconstructed via infocmp from file: /u/doc/terminfo/x/xterm
    xterm|xterm terminal emulator (X Window System),
            am, bce, km, mc5i, mir, msgr, npc, xenl,
            colors#8, cols#80, it#8, lines#24, pairs#64,
            acsc=``aaffggiijjkkllmmnnooppqqrrssttuuvvwwxxyyzz{{||}}~~,
            bel=^G, blink=\E[5m, bold=\E[1m, cbt=\E[Z,
            civis=\E[?25l, clear=\E[H\E[2J, cnorm=\E[?12l\E[?25h,
            cr=\r, csr=\E[%i%p1%d;%p2%dr, cub=\E[%p1%dD, cub1=\b,
            cud=\E[%p1%dB, cud1=\n, cuf=\E[%p1%dC, cuf1=\E[C,
            cup=\E[%i%p1%d;%p2%dH, cuu=\E[%p1%dA, cuu1=\E[A,
            cvvis=\E[?12;25h, dch=\E[%p1%dP, dch1=\E[P,
            dl=\E[%p1%dM, dl1=\E[M, ech=\E[%p1%dX, ed=\E[J,
            el=\E[K, el1=\E[1K, flash=\E[?5h$<100/>\E[?5l,
            home=\E[H, hpa=\E[%i%p1%dG, ht=\t, hts=\EH,
            ich=\E[%p1%d@, il=\E[%p1%dL, il1=\E[L, ind=\n,
            indn=\E[%p1%dS, invis=\E[8m,
            is2=\E[!p\E[?3;4l\E[4l\E>, kbs=\b, kb2=\EOE,
            kcbt=\E[Z, kcub1=\EOD, kcud1=\EOB, kcuf1=\EOC,
            kcuu1=\EOA, kdch1=\E[3~, kend=\EOF, kent=\EOM,
            kf1=\EOP, kf10=\E[21~, kf11=\E[23~, kf12=\E[24~,
            kf13=\E[1;2P, kf14=\E[1;2Q, kf15=\E[1;2R,
            kf16=\E[1;2S, kf17=\E[15;2~, kf18=\E[17;2~,
            kf19=\E[18;2~, kf2=\EOQ, kf20=\E[19;2~, kf21=\E[20;2~,
            kf22=\E[21;2~, kf23=\E[23;2~, kf24=\E[24;2~,
            kf25=\E[1;5P, kf26=\E[1;5Q, kf27=\E[1;5R,
            kf28=\E[1;5S, kf29=\E[15;5~, kf3=\EOR, kf30=\E[17;5~,
            kf31=\E[18;5~, kf32=\E[19;5~, kf33=\E[20;5~,
            kf34=\E[21;5~, kf35=\E[23;5~, kf36=\E[24;5~,
            kf37=\E[1;6P, kf38=\E[1;6Q, kf39=\E[1;6R, kf4=\EOS,
            kf40=\E[1;6S, kf41=\E[15;6~, kf42=\E[17;6~,
            kf43=\E[18;6~, kf44=\E[19;6~, kf45=\E[20;6~,
            kf46=\E[21;6~, kf47=\E[23;6~, kf48=\E[24;6~,
            kf49=\E[1;3P, kf5=\E[15~, kf50=\E[1;3Q, kf51=\E[1;3R,
            kf52=\E[1;3S, kf53=\E[15;3~, kf54=\E[17;3~,
            kf55=\E[18;3~, kf56=\E[19;3~, kf57=\E[20;3~,
            kf58=\E[21;3~, kf59=\E[23;3~, kf6=\E[17~,
            kf60=\E[24;3~, kf61=\E[1;4P, kf62=\E[1;4Q,
            kf63=\E[1;4R, kf7=\E[18~, kf8=\E[19~, kf9=\E[20~,
            khome=\EOH, kich1=\E[2~, kind=\E[1;2B, kmous=\E[M,
            knp=\E[6~, kpp=\E[5~, kri=\E[1;2A, kDC=\E[3;2~,
            kEND=\E[1;2F, kHOM=\E[1;2H, kIC=\E[2;2~, kLFT=\E[1;2D,
            kNXT=\E[6;2~, kPRV=\E[5;2~, kRIT=\E[1;2C, mc0=\E[i,
            mc4=\E[4i, mc5=\E[5i, op=\E[39;49m, rc=\E8, rev=\E[7m,
            ri=\EM, rin=\E[%p1%dT, rmacs=\E(B, rmam=\E[?7l,
            rmcup=\E[?1049l, rmir=\E[4l, rmkx=\E[?1l\E>,
            rmm=\E[?1034l, rmso=\E[27m, rmul=\E[24m, rs1=\Ec,
            rs2=\E[!p\E[?3;4l\E[4l\E>, sc=\E7, setab=\E[4%p1%dm,
            setaf=\E[3%p1%dm,
            setb=\E[4%?%p1%{1}%=%t4%e%p1%{3}%=%t6%e%p1%{4}%=%t1%e%p1%{6}%=%t3%e%p1%d%;m,
            setf=\E[3%?%p1%{1}%=%t4%e%p1%{3}%=%t6%e%p1%{4}%=%t1%e%p1%{6}%=%t3%e%p1%d%;m,
            sgr=%?%p9%t\E(0%e\E(B%;\E[0%?%p6%t;1%;%?%p2%t;4%;%?%p1%p3%|%t;7%;%?%p4%t;5%;%?%p7%t;8%;m,
            sgr0=\E(B\E[m, smacs=\E(0, smam=\E[?7h,
            smcup=\E[?1049h, smir=\E[4h, smkx=\E[?1h\E=,
            smm=\E[?1034h, smso=\E[7m, smul=\E[4m, tbc=\E[3g,
            u6=\E[%i%d;%dR, u7=\E[6n, u8=\E[?1;2c, u9=\E[c,
            vpa=\E[%i%p1%dd,
    

    But now Vim shows the special characters (or whatever they’re called) and not colors.

    mtputty_2017-11-21_15-43-40



  • 17.  RE: Vim 8.0.22 for z/OS released

    Posted 11-21-2017 03:54

    You have configured the TERMINFO database on the server, now you need to configure the TERMINFO database on the client. If you using putty set up Xterm R6
    2017 - 12:52:49



  • 18.  RE: Vim 8.0.22 for z/OS released

    Posted 11-21-2017 04:13

    I set that but it doesn’t fix the problem. I also tried it using Gnome terminal from a linux machine and that had the same problem. Hmmm, there’s a final missing piece to the jigsaw.



  • 19.  RE: Vim 8.0.22 for z/OS released

    Posted 11-21-2017 04:31

    If you use Linux client. So you can copy the local TERMINFO database to the server.
    using command
    on local machine

    infocmp > your_file

    copy this file on server and update TERMINFO database on server

    Better use the xterm or xterm-256color databases . On the server and on the client should be the same database.



  • 20.  RE: Vim 8.0.22 for z/OS released

    Posted 11-21-2017 04:38

    Try it xterm client on Linux.



  • 21.  RE: Vim 8.0.22 for z/OS released

    Posted 11-21-2017 07:26

    I’ve tried three different Linux systems using GUIs and terminals and none of them work. This must be environmental.



  • 22.  RE: Vim 8.0.22 for z/OS released

    Posted 11-21-2017 09:05

    Try this vim.tar.gz (249.7 KB)
    configuration files



  • 23.  RE: Vim 8.0.22 for z/OS released

    Posted 11-21-2017 10:22

    Have you uploaded a new version? I’ve just curled it onto a different system and it’s broken.



  • 24.  RE: Vim 8.0.22 for z/OS released

    Posted 11-21-2017 09:43

    RESULT! I had to tag the .vimrc file which was in ISO8859-1. Thank you so much.



  • 25.  RE: Vim 8.0.22 for z/OS released

    Posted 11-21-2017 09:48

    You guys should consider using *.pax.Z files instead of *.tar.gz which would preserve file tags and other file attributes.



  • 26.  RE: Vim 8.0.22 for z/OS released

    Posted 11-21-2017 09:53

    For the open source distribution bundles, we use tar with the -UX options, which preserves tags.

    https://www.ibm.com/support/knowledgecenter/SSLTBW_2.2.0/com.ibm.zos.v2r2.bpxa500/tar.htm



  • 27.  RE: Vim 8.0.22 for z/OS released

    Posted 11-21-2017 10:23

    Do you think tarballs are better than pax.Z files on z/OS? It’s certainly easier to use pax so I don’t have to pipe gzip into tar or run two commands.



  • 28.  RE: Vim 8.0.22 for z/OS released

    Posted 11-21-2017 10:45

    @daveyc Have you tried the -z option on tar instead of piping output to or from gzip?

      -z        Reads or writes, or both reads and writes, the tape archive by
                first passing through a compression algorithm compatible with
                that of compress.


  • 29.  RE: Vim 8.0.22 for z/OS released

    Posted 11-21-2017 10:50

    No I haven’t! Thanks for the tip. Is that Rockets tar port or the z/OS tar?



  • 30.  RE: Vim 8.0.22 for z/OS released

    Posted 11-21-2017 10:54

    We using the z/OS tar



  • 31.  RE: Vim 8.0.22 for z/OS released

    Posted 11-21-2017 10:54


  • 32.  RE: Vim 8.0.22 for z/OS released

    Posted 11-21-2017 10:59

    Just read that. I’m so used to using pax that I haven’t used tar for ages. Only on Linux systems. If that’s the case then maybe Rocket doco should use the -z option and not suggest using gzip?



  • 33.  RE: Vim 8.0.22 for z/OS released

    Posted 11-21-2017 11:17

    All goodness but I can’t put settings in .vimrc in my user directory without breaking it.



  • 34.  RE: Vim 8.0.22 for z/OS released

    Posted 11-22-2017 06:00

    correct archive vim.tar.gz (258.9 KB)



  • 35.  RE: Vim 8.0.22 for z/OS released

    Posted 11-22-2017 07:27

    Thanks @Yaroslav it’s all working well now. This is a great port. We’ve got a few Vim guys here and we’ve been trying stuff out like Vundle. There are some problems but it’s holding together to be more than usable. One nit is that map doesn’t seem to be working.