z/OS Tools & Language

Installing AWS CLI on USS z/OS gives SyntaxError: Non-UTF-8 code

  • 1.  Installing AWS CLI on USS z/OS gives SyntaxError: Non-UTF-8 code

    Posted 08-08-2017 23:39

    Hello,
    AWS requires Python 3.3+ as per instructions here
    docs aws amazon com cli latest userguide awscli-install-bundle

    I installed Python 3.6.1 release 2017-04-10 successfully.
    Nonetheless, when installing AWS CLI, I receive:

    python3 . awscli-bundle install -b ~ bin aws
    Running cmd: u ibmuser python python-2017-04-12-py36 python36 bin python virtualenv py --python u ibmuser python python-2017-04-12-py36 python36 bin python
    ibmuser .local lib aws
    Traceback (most recent call last):
    File “. awscli-bundle install”, line 138, in
    main()
    File “. awscli-bundle install”, line 128, in main
    create_install_structure(working_dir, opts.install_dir)
    File “. awscli-bundle install”, line 64, in create_install_structure
    _create_virtualenv(location=install_dir, working_dir=working_dir)
    File “. awscli-bundle install”, line 81, in _create_virtualenv
    location))
    File “. awscli-bundle install”, line 44, in run
    p.returncode, cmd, stdout + stderr))
    main.BadRCError: Bad rc (1) for cmd ’ u ibmuser python python-2017-04-12-py36 python36 bin python virtualenv py --python u ibmuser python python-2017-04-
    -py36 python36 bin python u ibmuser .local lib aws’: b’ File “virtualenv py”, line 1 nSyntaxError: Non-UTF-8 code starting with ’ x83 ’ in file virtualenv py on line 1, but no encoding declared n’

    It looks like Python is not able to read one of the Python file: virtualenv py
    Thanks, Phil