z/OS Tools & Language

Expand all | Collapse all

Sudo doesn't work

  • 1.  Sudo doesn't work

    Posted 04-16-2019 05:34

    Hi,

    I tried to install sudo (sudo-1.8.6p3_b009.170419) on z/OS 2.3. README.ZOS tells a alot about the installation process. But nothing about the customization of /ect/sudo.conf.

    When I run sudo with sample.conf delivered as sample an error occured that no sudoers.so was found.
    If I delete or comment the both lines in sudo.conf:
    Plugin sudoers_policy sudoers.so
    Plugin sudoers_io sudoers.so
    the execution of sudo fails with a message: unable to initialize policy plugin.

    How should sudo works with only the deliverd files in package sudo-1.8.6p3_b009.170419?

    Thanks for your help.

    Kind regards,
    Björn



  • 2.  RE: Sudo doesn't work

    Posted 07-16-2019 02:15

    Hi Björn,

    Did you try to use sudo.conf instead of sample.sudo.conf which goes in archive also.
    It doesn’t have links to sudoers.so
    Plugin sudoers_policy /etc/sudoers
    Plugin sudoers_io /etc/sudoers

    Thanks,
    Alexander