Rocket U2 | UniVerse & UniData

Expand all | Collapse all

Adjusting size of Unidata command history

  • 1.  Adjusting size of Unidata command history

    Posted 22 days ago
    Currently, I can list the last 60 commands.
    Can this be adjusted?

    ------------------------------
    Shawn Waldie
    Rocket Forum Shared Account
    ------------------------------


  • 2.  RE: Adjusting size of Unidata command history

    ROCKETEER
    Posted 22 days ago
    Edited by Mike Rajkowski 22 days ago
    Shawn,

    This is documented, but not the easiest to find.  (Search for 'command stack', since '.L' does not work well)

    It is in the 'Rocket UniData - Using UniData Version 8.2.2' manual:

    By default, UniData stores up to 49 commands in the command stack. To change the default, you can set the CSTACKSZ environment variable to save a specified number of command lines. Each command line can contain up to 2720 characters. See Administering UniData on UNIX
    or
    Administering UniData on Windows Platforms for information about setting UniData environment variables.

    Note: If you change the value of the CSTACKSZ environment variable on Windows platforms, you must restart UniData for the change to take effect.


    ------------------------------
    Mike Rajkowski
    support
    Rocket Internal - All Brands
    DENVER CO United States
    ------------------------------



  • 3.  RE: Adjusting size of Unidata command history

    Posted 22 days ago
    Thank you, Mike!

    I put the following in my .bashrc file, but it's not being honored:

    I also tried it in my .bash_profile, but that didn't seem to work either.

    I logged out and and back in in both cases, so I'm obviously missing something.

    ------------------------------
    Shawn Waldie
    Rocket Forum Shared Account
    ------------------------------



  • 4.  RE: Adjusting size of Unidata command history

    Posted 11 days ago
    Coming back to this one.

    We're on RHEL, and it has not been restarted.
    The result of executing the env command shows the following:

    I found a thread that suggested running source after setting an env variable though I haven't done that.

    Any other suggestions?

    ------------------------------
    Shawn Waldie
    Rocket Forum Shared Account
    ------------------------------



  • 5.  RE: Adjusting size of Unidata command history

    ROCKETEER
    Posted 11 days ago
    Shawn,

    That is strange, it works on my Linux System.

    You are adding additional commands at TCL before doing the .L100?

    It is possible you are hitting the same issue that is on Windows, and need to restart UniData, yet I did not when I tried.

    ------------------------------
    Mike Rajkowski
    support
    Rocket Internal - All Brands
    DENVER CO United States
    ------------------------------



  • 6.  RE: Adjusting size of Unidata command history

    Posted 11 days ago
    You are adding additional commands at TCL before doing the .L100?

    That's correct.
    And perhaps a restart is actually necessary.

    Thanks again!


    ------------------------------
    Shawn Waldie
    Rocket Forum Shared Account
    ------------------------------



  • 7.  RE: Adjusting size of Unidata command history

    Posted 4 days ago
    I think you're right, Mike.
    It looks like a restart is required for Unix platforms, as well.

    From appendix C of the Administering Unidata (v8.2.1) manual:

    ...something I haven't done yet.

    ------------------------------
    Shawn Waldie
    Rocket Forum Shared Account
    ------------------------------