Rocket Aldon

 View Only

 I am trying to set up a create command for CRTSQLRPGI with *SRVPGM

Robert Damery's profile image
Robert Damery posted 11-05-2021 14:58
Our ALDON set up already has CRTSQLRPGI for *MODULE and *PGM and I wanted to set up for *SRVPGM, but when we use option F6 to add it blows up....

Starting at ALDON main Menu using:
11. Setup menu
then 
4. Work with definitions of commands that create objects
and 
F6=Add definition
Jack Zhang's profile image
ROCKETEER Jack Zhang
Hi Robert, 

My apologies for the late response!  What does the screenshot look like on the panel before you attempted to add this entry? Do you have a joblog or spool file showing the errors when you tried to add it? 

For more prompt response, please open a customer support case in Rocket Community, and provide the requested information. If you have not done so, please register an account, so we'll have your contact information on records.

Thanks,
Jack Zhang
Dale Asher's profile image
ROCKETEER Dale Asher
Robert, 
Per Jack's earlier comment, please create a support case in the customer portal if we need to dig in further.
As he indicated, we would need to know the options attempted for Add of the create command.
Seeing below that SQLRPGLE is currently not an option for *SRVPGM.
CSELOATR                   Select Object Attribute               
                                                                 
Object type  . . . . . . :   *SRVPGM   Service Program           
                                                                 
Select one attribute by typing a / over the period, press Enter. 
                                                                 
                                                                 
   Attribute   Description                                       
.                    Service Program                             
.  CBLLE             CBL Service Program                         
.  CLE               C Service Program                           
.  CLLE              CL Service Program                          
.  CPPLE             C++ Service Program                         
.  RPGLE             RPG Service Program                         
Appears that you would need to create the Module first (as a requisite using SQLRPGLE) and then create the *SRVPGM specifying the Module for the create.
Please advise is this is still an issue for you.
Best, 
d
Robert Damery's profile image
Robert Damery
Sorry this forum interface is not, intuitive, I am using the Answer button to post a reply....I hope.
It appears our admin had to use a different domain and that worked.
Since the service program is only 1 module with embedded SQL I only needed the 1 command for an ILE object CRTSQLRPGLI it can create a MODULE/PGM/SRVPGM and in this instance I needed a Service program ....we already had set ups for PGM and Module. The command will create a temporary module then create the program and remove the module as it is NOT needed anywhere else....thanks for the replies I will work at learning this Forum process as it is cumbersome.
Dale Asher's profile image
ROCKETEER Dale Asher
Robert, 
I agree that this thread navigation seems odd.  I'm only seeing option to 'answer' as well.  Will be checking with the admin.
I would like to see your options used to add a new type for that create command and the error seen.
Regarding your question,  yes, for single-module *srvpgm, should be able to compile in qtemp in one go for the non-sql types.  I also know we can workaround creating *SRVPGM for a single module by registering two objects (the sqlrpgle module and a *srvpgm specifying the *module). 
Checking with LMi L3 support on why we do not seem to directly support the create for sqlrpgle *srvpgm 'like' we do for other (e.g. rpgle) *srvpgm in one step.  Wondering if we need to add a new *type for the crtsqlrpgli cmd for this requirement or use a custom create command to precompile the module and create the service pgm.
Hoping for an update from them in the morning.