z/OS Tools & Language

Expand all | Collapse all

Git blame not working

  • 1.  Git blame not working

    Posted 06-30-2020 21:12

    There seems to be a problem with git blame on z/OS.

    For example if I run git blame -L 14,+1 PARMLIB/IEASYS00 on a copy of a repository on my laptop I get this:

    41657ed0 (Gary Freestone (U70021A) 2020-06-10 11:30:25 +0000 14) GRS=STAR, MASTER OF GRS COMPLEX 00013100

    If I run the same command of z/OS I get the following:

    fatal: file PARMLIB/IEASYS00 has only 1 line

    Running git blame PARMLIB/IEASYS00 on z/OS I get this:

    00000000 (Not Committed Yet 2020-07-01 00:38:39 +0000 1)  <<|ä........................ íèç|²ñ! èñ|+.<ñ³è...
    FFFFFFFF44D9A4C9998AA884E8A4FFFF6FF6FF4FF7FF7FF44FFFF4F5444444333222222222222222222222455445454544424455222
    000000000D5630364493354085302020007001000A38A390E000001D01CCF3D00C000000000000000000001548F29A149FE0C934000
    

    Note:I only receive a single line of output. The second and third lines are hexadecimal display of the line I’m receiving.

    The first few characters after the date and time are X’414C4C4F433D30302C’ which is ASCII for “ALLOC=00,” which happens to be the first line of the file.

    So IMHO there seems to be a EBCDIC/ASCII problem with git blame.

    I am running git version “git version 2.14.4_zos_b08” on my z/OS system

    Regards, Gary



  • 2.  RE: Git blame not working

    Posted 07-03-2020 05:02

    Hi garyf,

    Thank you for your feedback. An internal ticket has been created for this issue.

    Thanks,
    Alex