Uniface User Forum

 View Only
  • 1.  Retrieve issues after Oracle Patch

    Posted 6 days ago
    Hi Unifacers ,

    We recently Patched/Updated Oracle to 19.14.0.0.220118 for some reason and now, retrieving using $date(Fieldname) has stopped working.
    Uniface version 9.6.06.01 (1125_1)

    After some investigating,  here's what we've noticed.

    (This retrieve has stopped working)
    clear/e "ent1"
    date_field.ent1 = $date(date_field.Ent2)
    Retrieve/e "ent1"
    error -2,
    ->hits 0
    (In debug, it generates a where clause "where  (date_field.ent1 = 11052022 00:00:00)

    (Work around-same data)
    So I moved the profile to the read trigger.

    read where "date_field =  '%%$date(date_field.ent2)"
    ->hits 1
    happy days :)

    (In debug, the generated where clause  (where date_field.ent1 = '11-may-2022')

    Is there a patch we need to install on uniface and if so, where do I find it,
    or is there a setting like $NLS_DATE_UNIFACE_PARSER  (which I've tried, but no joy).

    Rather than work around the issue, we prefer to fix the issue. 

    Thank you in advance for your help.

    Stanley 










    ------------------------------
    Stanley Odukoya
    Software Engineer
    Rocket Forum Shared Account
    ------------------------------


  • 2.  RE: Retrieve issues after Oracle Patch
    Best Answer

    ROCKETEER
    Posted 6 days ago
    Hi Stanely,

    Did you change anything on the Uniface side or did you just update Oracle? Not sure why you would think that this a Uniface problem. In case something that worked before breaks after installing a database patch then that seems to point to a problem with the database and not the calling program (i.e. Uniface).

    Would not be the first time that someone runs into a Oracle bug. If I remember it correctly then recently one of our customers had some problem after upgrading to Oracle 19.13. They had to roll back to their previous Oracle 19 patch level in order to get going again. But they had a problem with data truncation. Not sure if there is any relation with the issue you encounter.

    Some notes: the Uniface version you are using (version 9.6.06):

    1. Does not support Oracle 19; the highest Oracle version supported is 12c (with the ORA U7.1 driver);
    2. Is not supported anymore since some time; for details see the Uniface Support Lifecycle; it is advisable to upgrade to a supported version like Uniface 10.3.03 or 10.4.01
    For Oracle 19 (on Windows) you at least need Uniface 9.7.05 + patch 024 and the ORA U7.3 driver (see PAM9705-053.pdf).
    I hope this info is helpful. And I am sorry that I currently do not have a better answer for you.

    ------------------------------
    Daniel Iseli
    Principal Technical Support Engineer
    Uniface Services
    Rocket Software, Switzerland
    ------------------------------



  • 3.  RE: Retrieve issues after Oracle Patch

    Posted 3 days ago
    Hi Daniel,

    No changes were made to the uniface side. Only Oracle was updated/patched.

    Thank you for your response.
    It has helped with the decision to upgrade our version of uniface to a higher, supported version.

    Thank you for your time.





    ------------------------------
    Stanley Odukoya
    Software Engineer
    Rocket Forum Shared Account
    ------------------------------