D3 and mvBase

 View Only

 D3 10.4 (Linux) Shutdown command

Stefano Gallotta's profile image
PARTNER Stefano Gallotta posted 04-18-2024 05:39
Hi all
I know I posted this (somewhere) before but it got "lost"

I'm experiencing "hanging" after I issue a shutdown command with the new 10.4x on Linux.
Follow me through with this.
The shutdown command executes the odbc-setup command with a 'close' option (line 412)
The odbc-setup option expects a confirmation of this option (line 167) which it never receives (from the original shutdown command)

This results in the process "hanging" until a CR is issued.
Please confirm - because that's what I'm experiencing.
David Knight's profile image
PARTNER David Knight

Hi Stefano,

I think this was your post: https://community.rocketsoftware.com/question/d3-104x-shutdown

In that thread, one response states someone tried it on d3 Linux 10.4 and did not have that problem.

I have just checked our d3 Linux 10.3 version; and the shutdown and odbc-setup commands do not have source as you describe.

If you are correct and you have somehow not got another version of d3 mingled with your 10.4; then this sounds like a bug to be reported to Rocket via your usual channels.

You could test your hypothesis by temporarily modifying the shutdown source inserting a data command prior to executing odbc-setup so the prompt is always answered correctly according to the source of odbc-setup. Compile.

You would then have more to take to Rocket; which no doubt they would appreciate!

Don't forget to 'undo' your change.

I never advocate changing the source code of supplied systems. Report it back to Rocket!

Hope that helps.

Best wishes,

David Knight

Stefano Gallotta's profile image
PARTNER Stefano Gallotta

Hi @David Knight

The code is from a fresh 10.4 (Linux) installation - so no "mixed code.

Perhaps someone from Rocket may need to look at this.



Chris Macadam's profile image
ROCKETEER Chris Macadam

Hi Stefano,

You are correct that the problem is with the statement being executed to stop the ODBC server.  The fix is to add the 'q' option to the statement so that it looks like this:

execute "odbc-setup stop (q" Capturing xx

and recompile the 'shutdown' program.

Best regards.

Stefano Gallotta's profile image
PARTNER Stefano Gallotta

Thanks @Chris Macadam

That worked - Please include it in your next release :)