Open-source Languages & Tools for z/OS

 View Only

 Issues installing Miniconda

Divyanshu Singh's profile image
Divyanshu Singh posted 10-18-2022 13:15
Hi Team, 
I am installing Miniconda and while running the command for installing products, I get an unexpected error.
(Rocket) bash-4.3$ conda install - -file /shrd/miniconda/appdev_manifest_1.2.txt

# >>>>>>>>>>>>>>>>>>>>>> ERROR REPORT <<<<<<<<<<<<<<<<<<<<<<

Traceback (most recent call last):
File "/shrd/miniconda/v2/lib/python3.9/site-packages/conda/", line 819, in __call__
return func(*args, **kwargs)
File "/shrd/miniconda/v2/lib/python3.9/site-packages/conda/cli/", line 78, in _main
exit_code = do_call(args, p)
File "/shrd/miniconda/v2/lib/python3.9/site-packages/conda/cli/", line 77, in do_call
exit_code = getattr(module, func_name)(args, parser)
File "/shrd/miniconda/v2/lib/python3.9/site-packages/conda/cli/", line 11, in execute
install(args, parser, 'install')
File "/shrd/miniconda/v2/lib/python3.9/site-packages/conda/cli/", line 182, in install
specs.extend(common.specs_from_url(fpath, json=context.json))
File "/shrd/miniconda/v2/lib/python3.9/site-packages/conda/cli/", line 128, in specs_from_url
for line in open(path):
File "/shrd/miniconda/v2/lib/python3.9/", line 322, in decode
(result, consumed) = self._buffer_decode(data, self.errors, final)
UnicodeDecodeError: 'utf-8' codec can't decode byte 0xa2 in position 5: invalid start byte

An unexpected error has occurred. Conda has prepared the above report.
If submitted, this report will be used by core maintainers to improve
future releases of conda.

Any Idea why this could have been caused? Is that a product error or something wrong on the installation side?

Alexander Klochkov's profile image
ROCKETEER Alexander Klochkov
Hi Divyanshu,
Make sure that appdev_manifest_1.2.txt has the correct tag (ISO8859-1), is readable (cat appdev_manifest_1.2.txt gives normal output), and was copied in binary mode.
Divyanshu Singh's profile image
Divyanshu Singh
Hi Alex,

The file was not in bin format, so changing that worked, but while installing it showed python, pip and curl were not there to be installed, so it was failing because of that.
So, on removing python and curl from the text file. It worked. I don't know why python was not available.

Although my work was done.