Uniface User Forum

 View Only
Expand all | Collapse all

Sentiel issue(s)

  • 1.  Sentiel issue(s)

    Posted 26 days ago
    Edited by Knut Dybendahl 26 days ago

    Hey all,

    Trying to run 10.04 using an emergency license installed on one of our servers...

    Sentinel ain't playing ball....

    (Doesn't matter if I specify name of file or not)

    ASN settins
    $license_options=LM_LICENSE_FILE=<drive:><folder>\license\lservrc
    RMS Server: 210003 - Failed to resolve the server host "<drive>\userfolder\license\lservrc

    $license_options=LM_LICENSE_FILE=\\<hostname><folder>\license\lservc
    2301 - See Uniface Message Guide.\\frvdev4\frvis2024\licenseThe user name or password is incorrect.

    I've tried 6 ways to heaven and back - this ain't my first rodeo...
    Why on earth make it so darn difficult to configure??

    Anybody got any clues?

    Regards,
    Knut



    ------------------------------
    Knut Dybendahl
    ------------------------------



  • 2.  RE: Sentiel issue(s)

    Posted 26 days ago

    This is what uniface suggests for a specific file... dunno if that helps

    $LICENSE_OPTIONS=LM_LICENSE_FILE=D:\MyLicenses\myUnifaceLicense.xml, LM_NOTIFICATION=15, LM_TRANSCRIPT=15


    ------------------------------
    Osman Shariff
    ------------------------------



  • 3.  RE: Sentiel issue(s)

    Posted 25 days ago

    Hi,

    Unfortunately, the darn thing doesn't use an XML file.

    The errors above are not logical as I'm trying to use a license file rather than a server.

    Regards,

    Knut



    ------------------------------
    Knut Dybendahl
    ------------------------------



  • 4.  RE: Sentiel issue(s)

    ROCKETEER
    Posted 25 days ago

    Hi Knut,

    you'll need to place the Sentinel Emergency license on your local disk and address it in the used ASN file as:

    $license_options=LM_LICENSE_FILE=<localpath>\lservrc

    where you have to replace <localpath> for your real path to the license file.



    ------------------------------
    Nico Peereboom
    Uniface Anywhere Product specialist
    Principal Technical Support Engineer
    Rocket Internal - All Brands
    Amsterdam NL
    ------------------------------



  • 5.  RE: Sentiel issue(s)

    Posted 25 days ago

    Nico,

    That's exactly what I've done...

    The error messages are above...

    Regards,

    Knut



    ------------------------------
    Knut Dybendahl
    ------------------------------



  • 6.  RE: Sentiel issue(s)

    Posted 25 days ago

    Ciao Knut,

    just an hint: are you sure in your network UNC shares vs. MappedDriveAccess shares (X:) have same security profiles?

    I had found sometimes differences between them...

    Gianni



    ------------------------------
    Gianni Sandigliano
    IT
    ------------------------------



  • 7.  RE: Sentiel issue(s)

    Posted 25 days ago

    Hi Knut,

    According to instructions I received when migrating to Uniface 10.4 and Sentinel, the format I used for the $LICENSE_OPTIONS setting is:

    LM_LICENSE_FILE=<hostname including domain>

    So, not the path to the lservrc file but just the fully qualified hostname of the license server. This works for me.

    Hope this helps.



    ------------------------------
    Jim Mitchell
    State of Oregon
    Salem OR US
    ------------------------------



  • 8.  RE: Sentiel issue(s)

    Posted 25 days ago

    Hi Jim,

    Thank you for your suggestion - ;

    I'd say it would work for you because you're running the server itself.

    I (at this moment in time) haven't set up a license server - hence I'm just trying to point to the

    actual file itself.  And that's what's failing.

    Regards,

    Knut



    ------------------------------
    Knut Dybendahl
    ------------------------------



  • 9.  RE: Sentiel issue(s)

    Posted 19 days ago
      |   view attached

    Hello Knut,

    We are using the license file for a customer which is placed on a file share. This looks like the way you want to implement.

    For this customer an On-Premises Served license is used. In the usys.ini file we have in the path section the line usyslic=\\<server>\Uniface\License. In this folder the lservrc file, which contains the license data, should be placed. This can be a emergency license file. The share \\<server>\Uniface\License should be accessible for the user that will run the Uniface application.

    In the asn files, the line $LICENSE_OPTIONS LM_LICENSE_FILE=USYSLIC:lservrc is added. I think it is also possible to use the line $LICENSE_OPTIONS LM_LICENSE_FILE=\\<server>\Uniface\License\lservrc.

    For another customer we have installed the Sentinel License Manager service on a server. I have added the instruction we have used to install it on a Windows server. You need to adjust the paths as needed in your environment. In this case a Cloud-Served License is used. In the asn files, the line $LICENSE_OPTIONS LM_LICENSE_FILE=<hostname including domain> should be added. 



    ------------------------------
    Richard de Vries
    Sogeti Nederland B.V.
    NL
    ------------------------------

    Attachment(s)



  • 10.  RE: Sentiel issue(s)

    Posted 17 days ago

    Hi Richard,

    Thank you for your help and explanation.

    Regards,
    Knut



    ------------------------------
    Knut Dybendahl
    ------------------------------



  • 11.  RE: Sentiel issue(s)

    PARTNER
    Posted 17 days ago

    Hi Knut,
    As I'll probably soon get the same situation, ie. having to use an emergency licence, did you get it working by Richards explanation?
    What was the problem?
    As I understand it, the following
    "I think it is also possible to use the line $LICENSE_OPTIONS LM_LICENSE_FILE=\\<server>\Uniface\License\lservrc"
    was what you had tried.
    Did you have to define USYSLIC in ini-file?

    Regards RogerW.



    ------------------------------
    Roger Wallin
    Abilita Oy
    ------------------------------



  • 12.  RE: Sentiel issue(s)

    Posted 16 days ago

    Hi Roger,

    $license_options=lm_license_file=<path>\lservrc, lm_load=s

    The secret was the lm_load=s - apparently I am not running the latest version of 10.04.

    Regards,

    Knut



    ------------------------------
    Knut Dybendahl
    ------------------------------