Search

1 to 10 of 46
Sort by

Forum
Rocket Open-Source Languages and Tools for z/OS

Welcome to the Rocket Open Source Languages and Tools for z/OS forum. This is a place where you can ask questions about our open source languages and tools and get answers from other mainframe professionals like yourself, as well as members of the Rocket team.


Discussion Post
Use of config file by bash

I’ve just installed GNU bash, version 4.2.53(1)-release (i370-ibm-openedition) on Z/OS 2.3 and I’m somewhat confused by what config files bash uses at startup From …//share/doc/bash/4.3/README.ZOS the doc sartes Non-interactive mode The bash shell proceses configuration files in the...



Discussion Reply
RE: After new PERL 5.24 install - errors

teshaffer: Hello, I am trying to install the 5.24 version for our developers and since this is a first for me, as Perl was always apart on IBM Ported tools… I have followed the doc and added PATH, LIBPATH and PERL5LIB. But everytime they goto execute PERL. As soon as they hit the first perl...



Discussion Post
After new PERL 5.24 install - errors

Hello, I am trying to install the 5.24 version for our developers and since this is a first for me, as Perl was always apart on IBM Ported tools… I have followed the doc and added PATH, LIBPATH and PERL5LIB. But everytime they goto execute PERL. As soon as they hit the first perl statement,...


Discussion Reply
RE: Perldoc returns garbage characters

Hi, Thanks for using ported tools and reporting the issue. We have the same problem. I have created an internal ticket . I let you know, when we fix this. Thanks, Tatyana


Discussion Reply
RE: Error when executing change_pwd_perl.sh

Hi! Just wanted to update that I googled this a bit and it sounds like perllocal.pod customarily contains locally-installed modules not included with standard distribution. If that’s the case then the fact that this file is missing may be OK. I have proceeded without it for now anyway!



Discussion Post
Perldoc returns garbage characters

Hello! I couldn’t find any similar questions on this in the forum so I’ve posted my own. I recently installed perl 5.24 on zOS. When we use the perldoc command, for example ‘perldoc perlbot’, the command returns garbage characters along with valid text, like so: ^[1mNAME^[m perlbot - Links...