Skip to main content

Summary This article clarifies how to handle a lost connection  to an Artix router from the client side.
Environment

Artix 5.6.2 C

All Supported Operating Systems

Question/Problem Description

How to handle a lost connection to an Artix router on the Artix or .NET client side?

Do multiple Artix routers share state between them?

Clarifying Information

The Artix routers are used as protocol switches (SOAP/HTTP to CORBA) in order to expose the CORBA interfaces of the CORBA back-end as Web Services to Artix or .NET clients.

The routers only convert and pass the messages from the clients to the CORBA back-end and the responses from the backend to the client.

Routers do not save or replicate state (e.g client sessions) between each others.


The routers can register with the Artix locator, and when the clients lookup an endpoint through the Artix locator, the Artix locator returns a router instance in a round robin fashion if multiple routers are deployed and exposing the same endpoints.

Error Message
Defect/Enhancement Number
Cause
Resolution If a .NET or Artix client communicating to a CORBA back-end through an Artix router loses the connection to the router it will have to try re-connecting to the router instance. If this is not possible (due to machine crash, router crash, network to the machine down) the client can look-up a new endpoint  from the Artix locator. Given that the Artix locator and the routers keep each other in order to detect any failures, the Artix locator will be able to return an endpoint exposed by a different router. All WS-Addressing references the client holds to the inaccessible router will need to be refreshed through corresponding operations.
Workaround
Notes
Attachment

#KnowledgeDocs
#Orbix