Skip to main content

57V03 Cluster Status Request

  • December 31, 2014
  • 3 replies
  • 15 views

Rupendra
Forum|alt.badge.img+1
We are seeing following error message in vertica.log frequently in 2 out of 10 nodes in our Vertica cluster.
2014-12-29 03:33:55.312 Init Session:0x7f8f2bf68d80 <FATAL> @... : {SessionRun} 57V03/5785: Cluster Status Request by 12.0.0.109:53094        HINT:  Cluster State: ...
                UP: 10 of 10 (... ,...., ...)
                ----
        LOCATION:  initSession, /scratch_a/release/20490/vbuild/vertica/Session/ClientSession.cpp:436
We do not see any errors logged in error_messages, as well as there are no relevant messages in Management Console. Has anyone encounter similar issues?

Is there anyway to understand the source of this messages in log file?

We are using v7.1.1-2.

Thanks,
Rupendra

3 replies

pviennea
Forum|alt.badge.img
  • Participating Frequently
  • December 31, 2014
Hello Rupendra, this is most likely caused by the Management Console. Does an MC agent happen to sit on the 2 out of 10 nodes in your Vertica cluster?

Thanks

Pat

Rupendra
Forum|alt.badge.img+1
  • Author
  • Participating Frequently
  • January 1, 2015
Hi Patrick,

Thanks for the response. 

MC is installed in the first node of the cluster, but not in these two nodes. How to check if MC agent is there or not? I tried to check processes, but did not find anything related to MC agent.

Thanks,
Rupendra

pviennea
Forum|alt.badge.img
  • Participating Frequently
  • January 1, 2015
The errors are related to the MC pinging the nodes. Not sure why you are only seeing the FATAL on 2 of the 10 nodes. Have you reviewed all vertica.logs on each of the 10 nodes for the message?

I plan to create a enhancement/bug request to have this addressed. Maybe we change the FATAL to a WARNING or INFO or not post to the vertica.log by default.

You can verify cause is from MC by stopping the MC and then reviewing the vertica.logs. If the FATAL message persists it may be related to some other monitoring software?
To stop the MC run  /etc/init.d/vertica-consoled stop