Skip to main content

Backup data

  • January 29, 2018
  • 1 reply
  • 6 views

ashu123
Forum|alt.badge.img+1

Hello
I'm trying to backup vertica database data for the purpose of adding new node to it

[user_testing@localhost ~]$ /opt/vertica/bin/vbr --setupconfig
Warning: This setup tool is deprecated, and will be removed in a future version. Please use config file samples we provide in /opt/vertica/share/vbr/example_configs instead of using this tool.
Snapshot name (backup_snapshot): backup 
Number of restore points (1): 1
Specify objects (no default): 
Object restore mode (coexist, createOrReplace or create) (createOrReplace): createOrReplace
Vertica user name (user_testing): user_testing
Save password to avoid runtime prompt? (n) [y/n]: y
Database user password to save in vbr password config file (no default):
Node v_db_testing_0_node0001
Backup host name (no default):    
Backup directory (no default): /home/user_testing/backup
Change advanced settings? (n) [y/n]: n
Password file name (no default): pwdfile
Saved vbr password to pwdfile.
Config file name (backup.ini): backup.ini 
Saved vbr config to backup.ini.

[user_testing@localhost ~]$ vbr -t init -c /opt/vertica/config/vbr.ini
Error: Unable to connect to backup host via password-less SSH: 103.18.248.32.
Init FAILED.

How to backup my db :/

1 reply

Jim_Knicely
Forum|alt.badge.img+2
  • Participating Frequently
  • January 29, 2018

Hi,

One of the requirements so that the vbr utility can access a backup host is to have passwordless SSH access from each database cluster host to the corresponding backup host.

Check the "Setting Up Passwordless SSH Access" section in the following link for details:

https://my.vertica.com/docs/9.0.x/HTML/index.htm#Authoring/AdministratorsGuide/BackupRestore/ConfiguringBackupHosts.htm