Skip to main content

backup error

  • May 23, 2016
  • 2 replies
  • 20 views

Christine_1

Hi Everypone I am doing a backup job. And I got an error , which is a permission error saying /tmp/vbr/vbr.py :permission denied but i set the permission properly for dbadmin. Any idea? the backup directory is set up the same on all the nodes and permission is set the same. vertica version is 7.1.2

Any idea why? Help is appreaciated. 

2 replies

Rahul_Choudhary
Forum|alt.badge.img
  • Participating Frequently
  • May 24, 2016

Hi

 

Request you to make sure the below mentioned things are set properly:
 
1. Ensure that the "tmp" mount was not mounted with the "noexec" option. The script is first copied to /tmp on all nodes and executes from this location(If you have specified a directory other than /tmp in the vbr.ini config file, ensure that mount is not using the "noexec" option).
 
2. The dbadmin Linux user should have read/write/execute permissions for "/tmp". If this directory can not be written to, the process will fail.
 
Regards
Rahul

Christine_1
  • Author
  • New Participant
  • May 24, 2016

Thanks,Rahul. We found out the issue and it was the tmp folder. We used another folder to get away with this.