Vertica Backup Failing
Hi
I have inherited a database from a DBA that is no longer with the company, and one of the known issues is the lack of backup.
Node 1 has a NAS location (RAID 0+1) for the backup destination, which it serves as an NFS mount to the rest of the nodes. Performance has been checked using vioperf and it is excellent from all nodes in the cluster.
However, after successfully initializing the snapshot using "-t init", when I run the object level backup, it returns the following error:
$ vbr -t backup -c obj_bkp_husvm00-0.ini
Warning: config mapping is missing entries for nodes: (list of STANDBY nodes being ignored)
Starting backup of database PROD.
Objects: ['SCHEMA.tablename']
Participating nodes: (list of PERMANENT nodes to be backed up)
Enter vertica password:
Snapshotting database.
Snapshot complete.
Error: Missing critical file: [IP-address]:/path//Snapshots/obj_bkp_001_(timestamp)/v_PROD_node0018/obj_bkp_001.manifest
Backup FAILED.
If I go to the NAS mount point path on node 1, I don't see any directory named "Snapshots" - ignoring the weird "//" in the location.
Going to the node referenced by the IP-address (node 18), I also do not see any directory named Snapshots.
I assume this indicates that perhaps there must have been a failed backup in the past, which damaged the manifest, which for whatever reason is hidden from me?
How do I resolve/fix this?
Thanks in advance,
TH