When trying run a backup to properly setup remote backup host on a 3 node cluster, I get the following error. I can passwordless ssh in with no problem to the other cluster, however backup always fails with the below:
vbr.py --task backup --config-file backup2.ini
Copying...
1803: vbr client subproc on 10.0.0.106 terminates with returncode 1. Details in vbr_v_infoscout_node0002_client.log on that host.
Error msg: Host key verification failed.
Host key verification failed.
Traceback (most recent call last):
File "/tmp/vbr/vbr.py", line 2731, in work
remoteClient(args[0], args[1], args[2], args[3], args[4], args[5], args[6] == 'True')
File "/tmp/vbr/vbr.py", line 919, in remoteClient
ssList = subprocess.check_output(g["sshBackup"] + [sHost, cmd])
File "/opt/vertica/oss/python/lib/python2.7/subprocess.py", line 537, in check_output
raise CalledProcessError(retcode, cmd, output=output)
CalledProcessError: Command '['ssh', '-x', '10.0.0.249', 'ls -1 /data/infoscout_backup/v_infoscout_node0002']' returned non-zero exit status 255
Child processes terminated abnormally.
backup failed!
cleaning up...
1802: vbr client subproc on 10.0.0.105 terminates with returncode 2. Details in vbr_v_infoscout_node0001_client.log on that host.
Error msg: cancelled by SIGINT
1805: vbr client subproc on 10.0.0.107 terminates with returncode 255. Details in vbr_v_infoscout_node0003_client.log on that host.
Error msg: Killed by signal 2.
Retrying... #1
ERROR 4153: Node: v_infoscout_node0003: Cannot grab lock to create snapshot 'full_cluster_backup'. It might be used by others
When communicating with vertica, the process failed with code 1
backup failed!
Retrying... #2
ERROR 4153: Node: v_infoscout_node0003: Cannot grab lock to create snapshot 'full_cluster_backup'. It might be used by others
When communicating with vertica, the process failed with code 1
backup failed!