Skip to main content

backup Vertica 8.01 DB

  • November 16, 2017
  • 5 replies
  • 20 views

chern

Hi,
I used vbr utility to do the fully db backup and got the following message "Error: Error in snapshot manifest file: Malformed storage location line: 45035996273704984, dbfile/obrdb/v_obrdb​_node0001_data", I would appreciate if someone can help me solve this issue. Thanks.

5 replies

Jim_Knicely
Forum|alt.badge.img+2
  • Participating Frequently
  • November 16, 2017

Can you post the config file?


chern
  • Author
  • New Participant
  • November 17, 2017

Hi,
The following is the config file. Thanks.


chern
  • Author
  • New Participant
  • November 17, 2017

Hi,
Is it possible the config file is not the root cause ? since I found the location_path is dbfile/obrdb/v_obrdb_node0001_data thru the sql statement select * from storage_locations or the storage_path is dbfile/obrdb/v_obrdb_node0001_data thru the sql statement select * from disk_storage, those paths don't show the full paths, because I'm a newbie and don't know why only the backup process has the error and it doesn't affect other db processes. Thanks.


jheffner
Forum|alt.badge.img
  • Participating Frequently
  • November 21, 2017

You've unfortunately hit a bug in vbr; it does not correctly handle storage locations defined with relative paths. There's an issue filed and hopefully it will be fixed in an upcoming release.

For now, if possible I'd suggest that you migrate any data from this storage location to one with an absolute path, and drop the problematic location with the relative path. Using a relative path will put your data storage location underneath your catalog directory, which likely undesirable for other reasons as well.


chern
  • Author
  • New Participant
  • November 23, 2017

Okay, Thanks for your information.