Hi,
I've upgraded vertica from 7.1 to 7.2.3. My Vertica version is Vertica Analytic Database v7.2.3-9.
I would like to upgrade it to 8.0 (CE). Unfortunately when I try to stop my database via admintools (4. Stop Database) on the node (one node cluster) I am getting following error:
Error: Unable to connect to database.
Hint: Check authentication.
The other thing is when I choose another option (2. Connect to Database) I am able to login to database by providing the same password.
I've checked the logs in the /opt/vertica/log/adminTools.log and I have found following:
2017-05-12 09:08:19.944 at_exec/80077:0x7fa8a0e0f700 [vsql.connect] Exception when connecting: Error! pty.fork() failed: out of pty devices
Traceback (most recent call last):
File "/opt/vertica/oss/python/lib/python2.7/site-packages/vertica/network/vsql.py", line 174, in connect
self.pexpectConnection = pexpect.spawn(self.getExecuteVsql(), env=self.envVars)
File "/opt/vertica/oss/python/lib/python2.7/site-packages/vertica/utils/pexpect.py", line 429, in init
self._spawn (command, args)
File "/opt/vertica/oss/python/lib/python2.7/site-packages/vertica/utils/pexpect.py", line 537, in _spawn
raise ExceptionPexpect('Error! pty.fork() failed: ' + str(e))
ExceptionPexpect: Error! pty.fork() failed: out of pty devices
Could you please do let me know how can I safely stop the database ?