Skip to main content

Cannot backup vertica with messages after login

  • May 10, 2016
  • 4 replies
  • 19 views

Robert_Min

Hi experts,

 

We have 3 nodes of vertica, every machine has default login message, which means default message pop-up after login. When we try to backup our database, we failed. The output of command looks like that the default login pop-up message blocks the backup of other 2 nodes except the node in the operating machine.

I executed "/opt/vertica/bin/vbr.py --task listbackup –config-file backup.ini >XXXX.log" command to get the output, the log file is in the attachment.

Please help...

 

Regards,

Robert

 

4 replies

Gayatri_R
Forum|alt.badge.img
  • Participating Frequently
  • May 10, 2016

Hi Robert,

 

In your vbr cobfiguration file, I see

 

[Mapping]
v_itbadb_node0001 = localhost:/tmp/vertica_backup/
v_itbadb_node0002 = localhost:/tmp/vertica_backup/
v_itbadb_node0003 = localhost:/tmp/vertica_backup/

 

Looks like you are attempting to backup to the same node. Just replace localhost with the IP addresses of the nodes and re run the backup.

 

Thanks

Gayatri


Robert_Min
  • Author
  • New Participant
  • May 11, 2016

Thanks Gayatri,

 

I tried as you said, but it still cannot work. From my perspective, the backup host is where the backup files should locate, rather than where the node is, because Vertica itself will care where its nodes are, am I correct? I attached the log file after I execute the backup command.

 

Regards,

Robert


Gayatri_R
Forum|alt.badge.img
  • Participating Frequently
  • May 11, 2016

Hi Robert,

 

This time vbr is failing due to insufficient disk space on node2 and node3

 

rsync: writefd_unbuffered failed to write 4 bytes to socket [sender]: Broken pipe (32)
rsync: write failed on "/home/dbadmin/vertica_backup/v_itbadb_node0002/backup~new~/opt/vertica/itbadb/v_itbadb_node0002_catalog/Snapshots/catalog.ctlg": No space left on device (28)
rsync error: error in file IO (code 11) at receiver.c(302) [receiver=3.0.7]
rsync: connection unexpectedly closed (115 bytes received so far) [sender]
rsync error: error in rsync protocol data stream (code 12) at io.c(601) [sender=3.0.7]
rsync failed!

 

 

 

rsync: write failed on "/home/dbadmin/vertica_backup/v_itbadb_node0003/backup~new~/opt/vertica/itbadb/v_itbadb_node0003_catalog/Snapshots/catalog.ctlg": No space left on device (28)

 

 

Retry the backup after freeing up space on the vertica nodes or try to backup to different hosts.

 

Hope this helps.

 

Thanks

Gayatri


Robert_Min
  • Author
  • New Participant
  • May 16, 2016
Thank you Gayatri, The problem is solved. the rsync still got problem, if I set all the backup host to the first node machine, but at least it works when I backup separately. Regards, Robert