Skip to main content

Cannot ignore down host 127.0.0.1 - it is not being removed

  • May 23, 2016
  • 7 replies
  • 10 views

pmadu2000

Hello,

 

I am trying to install vertica on AWS, while installing vertica I am getting the following error message on both 127.0.0.1 and with my ip.

 

what could be the issue?

 

./install_vertica --hosts ip-10-x.x.x.ec2.internal --dba-user dbadmin --dba-user-password P@ssw0rd
Vertica Analytic Database 7.2.1-0 Installation Tool

AWS Detected. Using AWS defaults.
AWS Default: --data-dir was not specified, using default: /vertica/data
AWS Default: --dba-user-password-disabled was not specified, disabling dba password by default while on AWS
AWS Default: --point-to-point was not specified, enabling point-to-point spread communication by default while on AWS

>> Validating options...


Mapping hostnames in --hosts (-s) to addresses...
ip-ip-10-x.x.x.ec2.internal => 127.0.0.1

>> Starting installation tasks.
>> Getting system information for cluster (this may take a while)...

Warning: could not connect to 127.0.0.1:
Unable to connect as this user
Error: Cannot ignore down host 127.0.0.1 - it is not being removed
Hint: Establish connectivity to all cluster hosts before trying.
Installation FAILED with errors.

Installation stopped before any changes were made.

7 replies

Gayatri_R
Forum|alt.badge.img
  • Participating Frequently
  • May 25, 2016

Hi,

 

Your install_vertica command is missing a few parameters.

 

Please review and follow the AWS guide for installing Vertica on AWS : https://my.vertica.com/docs/Ecosystem/Amazon/UsingVerticaonAWSHTML/Default.htm

 

Thanks

Gayatri


pmadu2000
  • Author
  • New Participant
  • May 26, 2016

Hello Gayatri,

 

The link you had shared is not opeining, could you please share it again?

 

Thanks,

Madhu

 


System
  • New Participant
  • January 22, 2017

Hi -

 

Can you please let me know how was this resolved. I am facing the same thing while installing on AWS?

Should I specify the--point-to-point option?


Adrian_Oprea_1
Forum|alt.badge.img+1
  • Participating Frequently
  • January 23, 2017

 

You have to use the ip itself and not the host name given.

 

  Make sure you have edited your /etc/hosts file before installing the database, add you ip`s with thier specific node names.

 

 

And when you run install Vertica cluster use the ipaddreses. 

 

Checkout this video tutorials HP Vertica Tuts or See this articles for more info HP Vertica Setup


System
  • New Participant
  • January 23, 2017
Thanks! But i was already using IP address.Resolved the issue by adding the public key under /etc/ssh/authorized keys for root user. Also, to ignore down host / avoid the yes no promt for first sah loging, had to do a ssh-keyscan to add under /root/.ssh/known_hosts.

All in all problem was with root trying to login into the server while vertica installation - Vertica automatically spawns psuedo terminal to ssh while installation

Xerox
  • New Participant
  • April 2, 2022

please mention what public key where to collect it, can you provide steps please for all how it resolved. yes it is looking for ssh and password but how do i make it run


Xerox
  • New Participant
  • April 2, 2022

Error: Cannot ignore down host 12.10.168.72 - it is not being removed