Skip to main content

Changed IP addresses of cluster, unable to start database

  • February 1, 2016
  • 3 replies
  • 18 views

Ryan_Fitch_1
Forum|alt.badge.img+1

I have a 3 node POC cluster that was migrated to a different network. The IP addresses were changed and I can't bring up my old database. I am able to start a brand new one, but I would like to restore my old one if possible. I've changed every IP address I can find, but the database fails startup checks. I verified keyless ssh works, and can't find any references to the old ip's using recursive grep. Is there anything I can do to restore my old DB? Maybe import it into my new one?

 

7.2.1 Community Edition

Redhat 6 

3 replies

eli_revach
Forum|alt.badge.img+2
  • Participating Frequently
  • February 1, 2016

Hi ,

The IP address is embedded into the Vertica catalog files which are located on each one of the Vertica  nodes .

 

in order to change the IP's you need to edit this catalog files , the way to do that is by executing  the Vertica executable with  -D parameter, the procedure of update this catalog files is very delicate and you need to know what you doing otherwise you will corrupted the database . 

 

I advice you to take it with support 

 

I hope you will find it useful .

 

Thanks 


Adrian_Oprea_1
Forum|alt.badge.img+1
  • Participating Frequently
  • February 2, 2016

Hi, 

I guess that before you made any change to the *.conf file you have made a copy of the old ones ! right ? 

If this is true then restore your old config files and start your hosts using the old ipaddress. 

 

After the DB is up, backup the database, 

Install new cluster.

Create database. 

Restore the database.

 


martijnz
  • New Participant
  • February 2, 2016

The best thing you could do is to restore the old config file so you are able to start the Vertica Cluster again. Once you started the vertica cluster do the following: