Skip to main content

Column data is too big to store

  • May 13, 2016
  • 2 replies
  • 15 views

kushal_alester
Forum|alt.badge.img+1

Hi friends,

 

I am getting the below error in Vertica:

 

Error: [Vertica][VJDBC](4800) ERROR: String of 1772 octets is too long for type Varchar(255)

 

I can get rid of this issue using LONG VARCHAR datatype. or do you guys have others solution aprt from creating multiple columns into pieces.

 

Any performance issue using LONG VARCHAR ?

 

Thank you.

 

Regards,

Kushal

 

2 replies

eli_revach
Forum|alt.badge.img+2
  • Participating Frequently
  • May 13, 2016

Hi

You can still used regulare varchar column, the max length of regulare varchar is 65K chars 

 

Thanks 


kushal_alester
Forum|alt.badge.img+1
  • Author
  • Participating Frequently
  • May 13, 2016

Thanks!! The issue is resolved.