Skip to main content
Question

CONNECT SQL RETURNING ERRR

  • May 17, 2021
  • 5 replies
  • 7 views

SK21
Forum|alt.badge.img+2
  • Participating Frequently

Hello I am using connect utility so that i can transfer some data to test database but it is returning this error.
Checked with the network team and it looks fine from their side.
Can someone help here?
dbadmin=> CONNECT TO VERTICA vdb USER dbadmin PASSWORD 'vertica' ON '10.42.22.207',5433;
ERROR 2823: Could not connect to server [10.42.22.207]: Operation now in progress
Is the server running and accepting
TCP/IP connections on port 5433?

5 replies

Jim_Knicely
Forum|alt.badge.img+2
  • Participating Frequently
  • May 17, 2021

What happens if you run:

\! /opt/vertica/bin/vsql -d vdb -U dbadmin -w vertica -h 10.42.22.207

Are the database in different subnets?


SK21
Forum|alt.badge.img+2
  • Author
  • Participating Frequently
  • May 17, 2021

Hello @Jim_Knicely
Same trying to execute this on production(inet addr:10.65.3.7 Bcast:10.65.7.255 Mask:255.255.248.0)
to connect POC DB( inet 10.42.22.207 netmask 255.255.255.0 broadcast 10.42.22.255)
[dbadmin@verticadb-1 ~]$ /opt/vertica/bin/vsql -d vdb -U dbadmin -w vertica -h 10.42.22.207
vsql: could not connect to server: Connection timed out
Is the server running on host "10.42.22.207" and accepting
TCP/IP connections on port 5433?
You have mail in /var/spool/mail/dbadmin


Jim_Knicely
Forum|alt.badge.img+2
  • Participating Frequently
  • May 17, 2021

Can you ping 10.42.22.207 or ssh into it? If you can ssh into it, check if Vertica is running :)

Also, is there a public IP address for the POC node? Maybe you can connect to it?

/opt/vertica/bin/vsql -d vdb -U dbadmin -w vertica -h <<public ip-addres >>

If you can connect, you will have to change the export addresses on the nodes in prod (if possible).

See: Changing Node Export Address

Or, you can copy data using vsql. Say you want to copy data from table JIM in Prod to table JIM in POC:

/opt/vertica/bin/vsql -d vdb -U dbadmin -w vertica -h <<prod DB >> -c "SELECT * FROM jim;" | /opt/vertica/bin/vsql -d vdb -U dbadmin -w vertica -h <<POC DB >> -c "COPY jim FROM STDIN;" 

Unfortunately with a lot of data that might be kind of slow. But you can run alot of those COPY commands in parrallel.


SK21
Forum|alt.badge.img+2
  • Author
  • Participating Frequently
  • May 17, 2021

Hello @Jim_Knicely vertica is running in both clusters, ping is fine although ssh is not setup,can this be a possible problem?
Also are you sure about this command
/opt/vertica/bin/vsql -d vdb -U dbadmin -w vertica -h <> -c "SELECT * FROM jim;" | /opt/vertica/bin/vsql -d vdb -U dbadmin -w vertica -h <> -c "COPY jim FROM STDIN;"
I mean the starting of it vsql -d vdb? from prod server?


Jim_Knicely
Forum|alt.badge.img+2
  • Participating Frequently
  • May 17, 2021

No, you don't need SSH to be working. But if the database are different subnets, you have to change the EXPORT node addresses.

See: Configuring Network to Import and Export Data

For that command I sent, it first selects data from prod and then passes (i.e. pipes) the output to the second vsql commadn which loads it from standard in.