Skip to main content

Copycluster command fails with vertica 9.1.0.1

  • May 29, 2018
  • 1 reply
  • 3 views

hkhan

Hi,

I installed vertica 9.1.0.1 in a new cluster which had no previous instance of vertica. Created a database with the same name as the source cluster. I'm using the vbr script copy cluster command to sync data between two similar clusters, both has Vertica version 9.1.0.1.

Followed the same steps provided in the documentation
https://my.vertica.com/kb/Copying-Data-Between-Similar-Vertica-Clusters/Content/BestPractices/Copying-Data-Between-Similar-Vertica-Clusters.htm

The command fails with the following error message:
Error: Error getting cluster information from admintools.
Copycluster FAILED.

Trying to understand what went wrong in the process?

Thanks,
Haseeb

1 reply

Jim_Knicely
Forum|alt.badge.img+2
  • Participating Frequently
  • June 5, 2018

Are you adhering to the requirements?

Prerequisites:

  • The target cluster must have a different IP address than the source cluster.
  • The source and the target cluster must have the same:
  • Number of nodes
  • Node names

The databases on the source and target clusters must share the same:

  • dbadmin user
  • Database name
  • Vertica version

You must set up passwordless SSH between the source and the target clusters.

I think your issue might be that last requirement....