Skip to main content

dc_errors ( and possibly others) data collector table stops retaining data after a while.

  • June 9, 2015
  • 2 replies
  • 18 views

colin_loghin
Forum|alt.badge.img+2

It appears that dc_errors is empty despite a retention policy of  1000KB memory, 10GB(~) disk,

 

I noticed this on 2 different clusters running 7.1.1-x versions . The collection process restart after rerunning the 

SELECT SET_DATA_COLLECTOR_POLICY('Errors', '2000', '1000000'); with the same parameter. 

 

BEFORE

========

 

dbadmin=> SELECT GET_DATA_COLLECTOR_POLICY('Errors');

                   GET_DATA_COLLECTOR_POLICY                   

---------------------------------------------------------------

 1000KB kept in memory, 10000000KB kept on disk. kept on disk.

(1 row)

 

Time: First fetch (1 row): 86.923 ms. All rows formatted: 86.985 ms

dbadmin=> select count(*) from dc_errors;

 count 

-------

     0

(1 row)

 

Time: First fetch (1 row): 291.413 ms. All rows formatted: 291.498 ms

dbadmin=> select version();

               version               

-------------------------------------

 Vertica Analytic Database v7.1.1-10

(1 row)

 

AFTER 

======

 SET_DATA_COLLECTOR_POLICY 

---------------------------

 SET

(1 row)

 

Time: First fetch (1 row): 586.010 ms. All rows formatted: 586.971 ms

dbadmin=> select count(*) from dc_errors;

 count 

-------

     1

(1 row)

 

The data collector table shows no records and a lot of retired files.  This behavior is not according to data collector design in my opinion. Is this a bug in version 7 ? 

2 replies

DerrickR
Forum|alt.badge.img
  • Participating Frequently
  • June 10, 2015

Hi colin_loghin,

 

We do have a known issue with retention policy management in 7.1.1 that is scheduled to be resolved in 7.1.2 which we hope will be available shortly.

 

 


DerrickR
Forum|alt.badge.img
  • Participating Frequently
  • June 15, 2015

We just released 7.1SP2 which should have this issue resolved!

 

See https://community.dev.hp.com/t5/Vertica-Forum/HP-Vertica-7-1-SP2-is-now-available/m-p/230003#M10197