Skip to main content

default shell error

  • December 17, 2013
  • 16 replies
  • 44 views

dheeraj_thampy
Hi ,
I am tryng to install vertica 7
os is RH 6.4
3 nodes

when i run the install_vertica script, it throws the following error

Error: Default shell on the following nodes are not bash. Default shell must be set to bash.
<ip>  for <user>:
<ip2>  for <user>:
Exiting...
Installation FAILED with errors.

Installation stopped before any changes were made.


I double checked the bash details..the users in both nodes have /bin/bash as their default shell
anything else i need to check

kindly help

16 replies

Rahul_Choudhary
Forum|alt.badge.img
  • Participating Frequently
  • December 17, 2013
Hi Dheeraj

In order to fix this issue kindly perform below changes 

Note: Please perform below action on all the nodes.

# We run sudo commands over ssh, comment out the requirement that user needs to have a tty in order to run sudo commands # in /etc/sudoers, comment out the following line Defaults requiretty # or add the following line and exempt the dbadmin from tty Defaults:dbadmin !requiretty 

# This may also be necessary, configure sudo to either # (a) not ask for password, in /etc/sudoers dbadmin ALL=(ALL) NOPASSWD: ALL #OR (b) be prompted for a password dbadmin ALL=(ALL) PASSWD: ALL 

Kindly restart database installation afresh once again after making the above changes.

Regards
Rahul Choudhary

Daniel_Leybovic
Forum|alt.badge.img+1
  • Participating Frequently
  • December 17, 2013
Hi!

What is output of:
 echo $SHELL

dheeraj_thampy
  • Author
  • New Participant
  • December 17, 2013
Hi Rahul..
thanks for the quick reply , but that dint work out fr me ...

@Daniel
it gives me /bin/bash on all the nodes

dheeraj_thampy
  • Author
  • New Participant
  • December 18, 2013
Hi Rahul,
It worked for me...actually u wer right,..
i had to give the username of the sudo user instead of the dbadmin user (the second solution)

in /etc/sudoers

 <sudo user>  ALL=(ALL)  NOPASSWD: ALL


Thanks a lot friend :):)


Andrew_1
Forum|alt.badge.img
  • Participating Frequently
  • January 14, 2014
Hi,

I have a similar issue on Ubunutu 12.04.

Do you have a fix please?

Cheers
Andy

Daniel_Leybovic
Forum|alt.badge.img+1
  • Participating Frequently
  • January 14, 2014
Check this:  https://community.vertica.com/vertica/topics/vertica_7_nonetype_object_is_not_subscriptable_on_creat...

Check that loopback address  defined as 127.0.0.1 and not 127.0.1.1

Andrew_1
Forum|alt.badge.img
  • Participating Frequently
  • January 14, 2014
Thanks but I don't even get that far, I am installing a 3 node cluster and get the following when running the install_vertica script

when i run the install_vertica script, it throws the following error

Error: Default shell on the following nodes are not bash. Default shell must be set to bash.
<ip>  for <user>:
<ip2>  for <user>:
Exiting...
Installation FAILED with errors.

Installation stopped before any changes were made.

Cheers


Forum|alt.badge.img+2
  • Participating Frequently
  • January 15, 2014
Hi Andrew,

Did Rahul's fix work for you?  (Did you test it to make sure that sudo is working properly if you ssh into those nodes manually?)

If not, are you sure you have your shell set to bash?  Check both your dotfiles and the default in /etc/passwd .

If it's still not working, take a look at the installer log (in /opt/vertica/log/) and see if there's any more detail there.

Adam

Andrew_1
Forum|alt.badge.img
  • Participating Frequently
  • January 15, 2014
Thanks Adam,

Yes I have tried Rahul's fix and can confirm that sudo is working properly when I ssh onto the nodes.

I have set default in /etc/passwd on all nodes, which dotfiles are you refering to?

Cheers
Andy

Forum|alt.badge.img+2
  • Participating Frequently
  • January 15, 2014
I was thinking of ~/.bashrc, ~/.profile, etc.; the dotfiles that get run at login and that might set up the environment in a strange way in some cases.

That does seem somewhat unlikely, though...  I'd also suggest checking the installer log file to see if it says anything interesting.

Adam


Andrew_1
Forum|alt.badge.img
  • Participating Frequently
  • January 15, 2014
Have checked the dotfiles and nothing looks out of place.

Also have checked through the logs, there is no message log and cant see anything syslog, is there a log that the installation of vertica writes to?

Something must be causing the default shell to be changed when the installer runs......

Cheers
Andy

Forum|alt.badge.img+2
  • Participating Frequently
  • January 15, 2014
Per my previous comment, check out /opt/vertica/log/ .  Let us know if there's anything interesting there.

Thanks,
Adam

Andrew_1
Forum|alt.badge.img
  • Participating Frequently
  • January 16, 2014
Sorry, yes you did say and I did look before, there is nothing that I can see to be honest.

Any other ideas.

Thanks
Andy

Andrew_1
Forum|alt.badge.img
  • Participating Frequently
  • January 16, 2014
Just if it help, here are the details from the log

Jan 15 17:28:32  [adminExec.__init__] Unique Ports: False

Jan 15 17:28:32  <BashAdapter: dbadmin@10.0.0.8 sudo>: <command hidden>

Jan 15 17:28:32  <PexpectAdapter: dbadmin@10.0.0.4>: login start: ssh  -oConnectTimeout=30 -o TCPKeepAlive=no -o ServerAliveInterval=15 -o ServerAliveCountMax=2  -l dbadmin 10.0.0.4

Jan 15 17:28:39  <PexpectAdapter: dbadmin@10.0.0.5>: login start: ssh  -oConnectTimeout=30 -o TCPKeepAlive=no -o ServerAliveInterval=15 -o ServerAliveCountMax=2  -l dbadmin 10.0.0.5

Jan 15 17:28:42  <PexpectAdapter: dbadmin@10.0.0.5>: [ -f /etc/fedora-release ]

Jan 15 17:28:42  <PexpectAdapter: dbadmin@10.0.0.4>: [ -f /etc/fedora-release ]

Jan 15 17:28:42  <BashAdapter: dbadmin@10.0.0.8 sudo>: ['[ -f /etc/fedora-release ]']

Jan 15 17:28:42  <BashAdapter: dbadmin@10.0.0.8 sudo>: (rc=1) ['sudo: unable to resolve host vert01a']

Jan 15 17:28:42  <BashAdapter: dbadmin@10.0.0.8 sudo>: ['[ -f /etc/redhat-release ]']

Jan 15 17:28:42  <BashAdapter: dbadmin@10.0.0.8 sudo>: (rc=1) ['sudo: unable to resolve host vert01a']

Jan 15 17:28:42  <BashAdapter: dbadmin@10.0.0.8 sudo>: ['[ -f /etc/SuSE-release ]']

Jan 15 17:28:42  <BashAdapter: dbadmin@10.0.0.8 sudo>: (rc=1) ['sudo: unable to resolve host vert01a']

Jan 15 17:28:42  <BashAdapter: dbadmin@10.0.0.8 sudo>: ['[ -f /etc/debian_version ]']

Jan 15 17:28:42  <BashAdapter: dbadmin@10.0.0.8 sudo>: (rc=0) ['sudo: unable to resolve host vert01a']

Jan 15 17:28:42  <BashAdapter: dbadmin@10.0.0.8 sudo>: ['grep "^4." /etc/debian_version']

Jan 15 17:28:42  <BashAdapter: dbadmin@10.0.0.8 sudo>: (rc=1) ['sudo: unable to resolve host vert01a']

Jan 15 17:28:42  <BashAdapter: dbadmin@10.0.0.8 sudo>: ['grep "^5." /etc/debian_version']

Jan 15 17:28:42  <BashAdapter: dbadmin@10.0.0.8 sudo>: (rc=1) ['sudo: unable to resolve host vert01a']

Jan 15 17:28:42  <BashAdapter: dbadmin@10.0.0.8 sudo>: ['grep "^6." /etc/debian_version']

Jan 15 17:28:42  <BashAdapter: dbadmin@10.0.0.8 sudo>: (rc=1) ['sudo: unable to resolve host vert01a']

Jan 15 17:28:42  <BashAdapter: dbadmin@10.0.0.8 sudo>: ['grep "wheezy" /etc/debian_version']

Jan 15 17:28:42  <BashAdapter: dbadmin@10.0.0.8 sudo>: (rc=0) ['wheezy/sid', 'sudo: unable to resolve host vert01a']

Jan 15 17:28:42  <BashAdapter: dbadmin@10.0.0.8 sudo>: ['LANG=C /sbin/ifconfig']

Jan 15 17:28:42  <BashAdapter: dbadmin@10.0.0.8 sudo>: (rc=0) ['eth0      Link encap:Ethernet  HWaddr fa:16:3e:83:f6:3d  ', '          inet addr:10.0.0.8  Bcast:10.0.0.255  Mask:255.255.255.0', '          inet6 addr: fe80::f816:3eff:fe83:f63d/64 Scope:Link', '          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1', '          RX packets:4771 errors:0 dropped:0 overruns:0 frame:0', '          TX packets:4151 errors:0 dropped:0 overruns:0 carrier:0', '          collisions:0 txqueuelen:1000 ', '          RX bytes:503425 (503.4 KB)  TX bytes:718741 (718.7 KB)', '', 'lo        Link encap:Local Loopback  ', '          inet addr:127.0.0.1  Mask:255.0.0.0', '          inet6 addr: ::1/128 Scope:Host', '          UP LOOPBACK RUNNING  MTU:16436  Metric:1', '          RX packets:12 errors:0 dropped:0 overruns:0 frame:0', '          TX packets:12 errors:0 dropped:0 overruns:0 carrier:0', '          collisions:0 txqueuelen:0 ', '          RX bytes:720 (720.0 B)  TX bytes:720 (720.0 B)', 'sudo: unable to resolve host vert01a']

Jan 15 17:28:42  <BashAdapter: dbadmin@10.0.0.8 sudo>: ["dpkg -s vertica 2>&1 | grep Status | awk '{print $2}'"]

Jan 15 17:28:42  <PexpectAdapter: dbadmin@10.0.0.5>: (rc=1) []

Jan 15 17:28:42  <PexpectAdapter: dbadmin@10.0.0.5>: [ -f /etc/redhat-release ]

Jan 15 17:28:42  <PexpectAdapter: dbadmin@10.0.0.4>: (rc=1) []

Jan 15 17:28:42  <PexpectAdapter: dbadmin@10.0.0.4>: [ -f /etc/redhat-release ]

Jan 15 17:28:42  <BashAdapter: dbadmin@10.0.0.8 sudo>: (rc=0) ['install']

Jan 15 17:28:42  <BashAdapter: dbadmin@10.0.0.8 sudo>: ["dpkg -l vertica | tail -1 | awk '{print $3}'"]

Jan 15 17:28:42  <PexpectAdapter: dbadmin@10.0.0.5>: (rc=1) []

Jan 15 17:28:42  <PexpectAdapter: dbadmin@10.0.0.5>: [ -f /etc/SuSE-release ]

Jan 15 17:28:42  <PexpectAdapter: dbadmin@10.0.0.4>: (rc=1) []

Jan 15 17:28:42  <PexpectAdapter: dbadmin@10.0.0.4>: [ -f /etc/SuSE-release ]

Jan 15 17:28:42  <BashAdapter: dbadmin@10.0.0.8 sudo>: (rc=0) ['7.0.0-1', 'sudo: unable to resolve host vert01a']

Jan 15 17:28:42  [Profile.VerticaRelease] query results '7.0.0-1'

Jan 15 17:28:42  <PexpectAdapter: dbadmin@10.0.0.5>: (rc=1) []

Jan 15 17:28:42  <PexpectAdapter: dbadmin@10.0.0.5>: [ -f /etc/debian_version ]

Jan 15 17:28:42  <PexpectAdapter: dbadmin@10.0.0.4>: (rc=1) []

Jan 15 17:28:42  <PexpectAdapter: dbadmin@10.0.0.4>: [ -f /etc/debian_version ]

Jan 15 17:28:43  <PexpectAdapter: dbadmin@10.0.0.5>: (rc=0) []

Jan 15 17:28:43  <PexpectAdapter: dbadmin@10.0.0.5>: grep "^4." /etc/debian_version

Jan 15 17:28:43  <PexpectAdapter: dbadmin@10.0.0.4>: (rc=0) []

Jan 15 17:28:43  <PexpectAdapter: dbadmin@10.0.0.4>: grep "^4." /etc/debian_version

Jan 15 17:28:43  <PexpectAdapter: dbadmin@10.0.0.5>: (rc=1) []

Jan 15 17:28:43  <PexpectAdapter: dbadmin@10.0.0.5>: grep "^5." /etc/debian_version

Jan 15 17:28:43  <PexpectAdapter: dbadmin@10.0.0.4>: (rc=1) []

Jan 15 17:28:43  <PexpectAdapter: dbadmin@10.0.0.4>: grep "^5." /etc/debian_version

Jan 15 17:28:43  <PexpectAdapter: dbadmin@10.0.0.5>: (rc=1) []

Jan 15 17:28:43  <PexpectAdapter: dbadmin@10.0.0.5>: grep "^6." /etc/debian_version

Jan 15 17:28:43  <PexpectAdapter: dbadmin@10.0.0.4>: (rc=1) []

Jan 15 17:28:43  <PexpectAdapter: dbadmin@10.0.0.4>: grep "^6." /etc/debian_version

Jan 15 17:28:43  <PexpectAdapter: dbadmin@10.0.0.5>: (rc=1) []

Jan 15 17:28:43  <PexpectAdapter: dbadmin@10.0.0.5>: grep "wheezy" /etc/debian_version

Jan 15 17:28:43  <PexpectAdapter: dbadmin@10.0.0.4>: (rc=1) []

Jan 15 17:28:43  <PexpectAdapter: dbadmin@10.0.0.4>: grep "wheezy" /etc/debian_version

Jan 15 17:28:43  <PexpectAdapter: dbadmin@10.0.0.5>: (rc=0) ['\x1b[01;31m\x1b[Kwheezy\x1b[m\x1b[K/sid']

Jan 15 17:28:43  <PexpectAdapter: dbadmin@10.0.0.5>: LANG=C /sbin/ifconfig

Jan 15 17:28:43  <PexpectAdapter: dbadmin@10.0.0.4>: (rc=0) ['\x1b[01;31m\x1b[Kwheezy\x1b[m\x1b[K/sid']

Jan 15 17:28:43  <PexpectAdapter: dbadmin@10.0.0.4>: LANG=C /sbin/ifconfig

Jan 15 17:28:44  <PexpectAdapter: dbadmin@10.0.0.5>: (rc=0) ['eth0      Link encap:Ethernet  HWaddr fa:16:3e:df:af:91  ', '          inet addr:10.0.0.5  Bcast:10.0.0.255  Mask:255.255.255.0', '          inet6 addr: fe80::f816:3eff:fedf:af91/64 Scope:Link', '          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1', '          RX packets:7811 errors:0 dropped:0 overruns:0 frame:0', '          TX packets:5815 errors:0 dropped:0 overruns:0 carrier:0', '          collisions:0 txqueuelen:1000 ', '          RX bytes:10988842 (10.9 MB)  TX bytes:720096 (720.0 KB)', '', 'lo        Link encap:Local Loopback  ', '          inet addr:127.0.0.1  Mask:255.0.0.0', '          inet6 addr: ::1/128 Scope:Host', '          UP LOOPBACK RUNNING  MTU:16436  Metric:1', '          RX packets:0 errors:0 dropped:0 overruns:0 frame:0', '          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0', '          collisions:0 txqueuelen:0 ', '          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)', '']

Jan 15 17:28:44  <PexpectAdapter: dbadmin@10.0.0.5>: dpkg -s vertica 2>&1 | grep Status | awk '{print $2}'

Jan 15 17:28:44  <PexpectAdapter: dbadmin@10.0.0.4>: (rc=0) ['eth0      Link encap:Ethernet  HWaddr fa:16:3e:b8:0b:00  ', '          inet addr:10.0.0.4  Bcast:10.0.0.255  Mask:255.255.255.0', '          inet6 addr: fe80::f816:3eff:feb8:b00/64 Scope:Link', '          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1', '          RX packets:13246 errors:0 dropped:0 overruns:0 frame:0', '          TX packets:7791 errors:0 dropped:0 overruns:0 carrier:0', '          collisions:0 txqueuelen:1000 ', '          RX bytes:11490463 (11.4 MB)  TX bytes:1184232 (1.1 MB)', '', 'lo        Link encap:Local Loopback  ', '          inet addr:127.0.0.1  Mask:255.0.0.0', '          inet6 addr: ::1/128 Scope:Host', '          UP LOOPBACK RUNNING  MTU:16436  Metric:1', '          RX packets:0 errors:0 dropped:0 overruns:0 frame:0', '          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0', '          collisions:0 txqueuelen:0 ', '          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)', '']

Jan 15 17:28:44  <PexpectAdapter: dbadmin@10.0.0.4>: dpkg -s vertica 2>&1 | grep Status | awk '{print $2}'

Jan 15 17:28:44  <PexpectAdapter: dbadmin@10.0.0.5>: (rc=0) []

Jan 15 17:28:44  <PexpectAdapter: dbadmin@10.0.0.4>: (rc=0) []

Jan 15 17:28:44  <PexpectAdapter: dbadmin@10.0.0.5>: closeConnection

Jan 15 17:28:44  <PexpectAdapter: dbadmin@10.0.0.4>: closeConnection

Jan 15 17:28:45  Hosts to add: ['10.0.0.8', '10.0.0.4', '10.0.0.5']

Jan 15 17:28:45  Hosts to remove: []

Jan 15 17:28:45  Hosts to update: []

Jan 15 17:28:45  Resulting cluster: ['10.0.0.8', '10.0.0.4', '10.0.0.5']

Jan 15 17:28:45  <PexpectAdapter: dbadmin@10.0.0.5 sudo>: login start: ssh  -oConnectTimeout=30 -o TCPKeepAlive=no -o ServerAliveInterval=15 -o ServerAliveCountMax=2  -l dbadmin 10.0.0.5

Jan 15 17:28:45  <PexpectAdapter: dbadmin@10.0.0.4 sudo>: login start: ssh  -oConnectTimeout=30 -o TCPKeepAlive=no -o ServerAliveInterval=15 -o ServerAliveCountMax=2  -l dbadmin 10.0.0.4

Jan 15 17:28:45  <BashAdapter: dbadmin@10.0.0.8 sudo>: <command hidden>

Jan 15 17:28:47  <BashAdapter: dbadmin@10.0.0.8 sudo>: <command hidden>

Jan 15 17:28:47  <PexpectAdapter: dbadmin@10.0.0.4 sudo>: <command hidden>

Jan 15 17:28:47  <PexpectAdapter: dbadmin@10.0.0.5 sudo>: <command hidden>

Jan 15 17:28:47  <PexpectAdapter: dbadmin@10.0.0.5 sudo>: closeConnection

Jan 15 17:28:48  <PexpectAdapter: d

Andrew_1
Forum|alt.badge.img
  • Participating Frequently
  • January 18, 2014
Hi,

Any other thoughts on this??

Cheers
Andy

John_Robinson
  • New Participant
  • February 13, 2015
To solve this, I just commented out in this file:

   /opt/vertica/oss/python/lib/python2.7/site-packages/vertica/install/__init__.py

the last line of these 3:

    # Can we manage to delete this check?  The create_dba script does this check

    # and I think all of the relevant adapters start bash explicitly.

    check_default_shell(fullhostname_list, installerSSH)

That is, I did what the comment suggested.  I could not figure out why the check failed (python novice).