Skip to main content

Error: failed to get network profiles Could not find a suitable network interface:

  • June 2, 2015
  • 5 replies
  • 24 views

UJJWAL_RANA
Forum|alt.badge.img+2

Hi,

I am getting following error message while creating database from admintools . I wonder how do I solved the below error. If any more information is required then please do not hesitate.

 

[dbadmin@storage ~]$ /opt/vertica/bin/admintools

 

*** Creating database: VMart ***
            192.168.0.1 OK [vertica][(7, 1, 1)][000][x86_64]
    Error: failed to get network profiles
    Could not find a suitable network interface: 192.168.0.1
Press RETURN to continue

 

Here is the  host information

 

[dbadmin@storage ~]$ hostname
storage.example.com
[dbadmin@storage ~]$

 

 

[dbadmin@storage ~]$ ping storage.example.com
PING storage.example.com (192.168.0.1) 56(84) bytes of data.
64 bytes from storage.example.com (192.168.0.1): icmp_seq=1 ttl=128 time=358 ms
64 bytes from storage.example.com (192.168.0.1): icmp_seq=2 ttl=128 time=276 ms
64 bytes from storage.example.com (192.168.0.1): icmp_seq=3 ttl=128 time=337 ms
^C
--- storage.example.com ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2697ms
rtt min/avg/max/mdev = 276.181/324.181/358.374/34.953 ms


[dbadmin@storage ~]$

 

 

[root@storage network-scripts]# more ifcfg-eth0
DEVICE=eth0
HWADDR=00:0C:29:CF:65:45
TYPE=Ethernet
IPADDR=192.168.0.1
NETMASK=255.255.255.0
ONBOOT=yes
BOOTPROTO=dhcp
USERCTL=no


[root@storage network-scripts]#

5 replies

DerrickR
Forum|alt.badge.img
  • Participating Frequently
  • June 2, 2015

Hello,

 

What does ipconfig or `ip addr` show for the machine at 192.168.0.1?


UJJWAL_RANA
Forum|alt.badge.img+2
  • Author
  • Participating Frequently
  • June 2, 2015

[root@storage dbadmin]# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:0C:29:CF:65:45  
          inet addr:192.168.192.130  Bcast:192.168.192.255  Mask:255.255.255.0
          inet6 addr: fe80::20c:29ff:fecf:6545/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:83262 errors:0 dropped:0 overruns:0 frame:0
          TX packets:26834 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:75324209 (71.8 MiB)  TX bytes:5383113 (5.1 MiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:50 errors:0 dropped:0 overruns:0 frame:0
          TX packets:50 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:4450 (4.3 KiB)  TX bytes:4450 (4.3 KiB)

[root@storage dbadmin]#


DerrickR
Forum|alt.badge.img
  • Participating Frequently
  • June 2, 2015

I believe that the installer is confused because you refer to the node as 192.168.0.1 but it doesn't have a local address by that name.

 

Is this a cluster or a single node?

 

Are you running AdminTools locally or from some other address?

 

Keep in mind that Vertica cannot run with NAT between hosts.


UJJWAL_RANA
Forum|alt.badge.img+2
  • Author
  • Participating Frequently
  • June 2, 2015

I am running local server for test purpose on VMWARE WORKSTATION 10. I was just thinking of doing NAT. Please advice if there is any other options.


DerrickR
Forum|alt.badge.img
  • Participating Frequently
  • June 2, 2015

If you are only installing on a single node and don't intend to later add more nodes to the database, you should use 127.0.0.1 as the hostname.