Skip to main content

Error In Loading File of 2GB

  • February 16, 2015
  • 3 replies
  • 23 views

Madhu_Sudhan_Re
Hi All

I have created following Table and faced an error 

Create Table Reference(col1 varchar(20) , col2 integer ,col3 varchar(20) );

 copy Reference  from '/home/dbadmin/Reference.txt' delimiter '|';

Then I have faced the Following error 

ERROR 2344:  Cannot allocate sufficient memory for COPY statement (536870912 requested, 268435456 permitted)
HINT:  This can happen if you have very wide rows, or if you have specified an incorrect record terminator.  (Check your escaping -- for example, "'    '" is not a tab; you must use "E'       '".)

Note :My reference.txt file is 2gb large and it is delimited with '|' 

Can anyone Help

3 replies

Bill_West_1
  • New Participant
  • February 17, 2015
You might have to verify that there is a newline chraracter at the end of each line in the file and specify it in your copy statement. A lot of times a file prepared in Windows will not have a line terminator that is understood by a *nix system when it is being processed.

Massimo_Loporch
Forum|alt.badge.img+1
  • Participating Frequently
  • February 17, 2015

Rahul_Choudhary
Forum|alt.badge.img
  • Participating Frequently
  • February 19, 2015
Hi 

Since you are trying to load data in excess of couple of gbs I will also suggest you to kindly use the "DIRECT" keyword in your above statement since as per vertica recommendation if the load is greater than 100mb it is suggested to load data directly into ROS & that can be done by using "DIRECT"keyword.

Regards
Rahul Choudhary