Skip to main content

Error starting database with no good epoch (epoch 0)

  • February 22, 2015
  • 4 replies
  • 24 views

OLEG_SALTANOVIC
Error starting database after unexpected restart. No good epoch. No backup.

How we can resolve this?

Vertica.log:
2015-02-22 10:57:44.140 Main:0x745e930 [Init] <INFO> Startup [Check Storage] Removing unnecessary storage files2015-02-22 10:57:44.153 Main:0x745e930 [Init] <INFO> Startup [Check Storage] Confirming storage matches catalog (files) - 0 / 216
2015-02-22 10:57:44.153 Main:0x745e930 [Catalog] <INFO> Checking 216 files in 2 threads
2015-02-22 10:57:44.154 nameless:0x78b72b0 [Catalog] <WARNING> Error getting size of file [/media/twingo/49d27a86-4ffd-4837-8319-2da68cc1bfea/vertica_data/811/45035996273930811/45035996273930811_0.fdb]: No such file or directory
2015-02-22 10:57:44.154 nameless:0x79505c0 [Catalog] <WARNING> Error getting size of file [/media/twingo/49d27a86-4ffd-4837-8319-2da68cc1bfea/vertica_data/493/45035996273931493/45035996273931493_0.fdb]: No such file or directory
2015-02-22 10:57:44.154 nameless:0x78b72b0 <WARNING> @v_meta_networks_node0001: 01000/3938: MiniRos 45035996273930811 does not have proper SAL files
2015-02-22 10:57:44.154 nameless:0x79505c0 <WARNING> @v_meta_networks_node0001: 01000/3938: MiniRos 45035996273931493 does not have proper SAL files

4 replies

id10t
Forum|alt.badge.img
  • Participating Frequently
  • February 23, 2015
Hi!

Nno worries, you have CSV files as backup in - /archive dir. Database isn't so big, to reload data will take about 2 hours ;)

Cheers :)

Oleg_Saltanovic_1
Hi Daniel! I'am not worry, it's only developer database with 0.5 TB of data. I take it as a case study and want to learn how we can to reanimate the server. Any ideas?

id10t
Forum|alt.badge.img
  • Participating Frequently
  • February 23, 2015
In this case you have no choice, only a backup or may be only with fsck.
The problem here is -
/media/twingo/...
or its a bad system configuration or its a bad hardware planing.
man hier
...
/media This directory contains mount points for removable media such as CD and DVD disks or USB sticks.
...
I bet on a second. 
Only an advise - if you will continue to use in mountable USB disk as a storage you will need to advance an epoch more frequently. You can do it manually or you can reconfigure Vertica to do it more frequently.

Remember - Vertica is a disk based database ;)

cheers

Oleg_Saltanovic_1
Thanks you very much for your participation! I'll try to repair fs by fsck. I think you're right - a problem in system configuration, but /media/twingo/... it's a internal HDD...