Skip to main content
Question

Fail of HDFS_CLUSTER_CONFIG_CHECK(); at Active Directory - Kerberos

  • March 21, 2019
  • 2 replies
  • 14 views

keehoonlee
Forum|alt.badge.img

Hi experts,

I am on PoC with Active Directory - Kerberos - Hadoop (Cloudera). After integrating Vertica with Kerberoized Active Directory. I've ran external_config_check() and saw fail message.

The failing part is "HDFS_CLUSTER_CONFIG_CHECK();"

It shows :
(admin user is "vertica", insted of "dbadmin" here)

[ERROR] [vertica] failed to connect due to 'hdfs:///: stat failed; error; connection timed out'
vertica : [FAIL]
[ERROR] [verticadbuser] failed to connect due to 'hdfs:///: stat failed; error; connection timed out'
verticadbuser : [FAIL]

I wonder for the kerberos enable enviroment, is there any work to do at HDFS site? Any comment will be very helpful.

2 replies

SruthiA
Forum|alt.badge.img+1
  • Participating Frequently
  • March 21, 2019

Is CURL working from vertica cluster? What is the output of the CURL list status?

curl -i -L --negotiate -u:username "http://hadoopNameNode:50070/webhdfs//v1/?op=LISTSTATUS"


keehoonlee
Forum|alt.badge.img
  • Author
  • Participating Frequently
  • March 21, 2019

Issue resolved after modifiying hostfile