Hi,
HP Vertica doesn't appear to allow creating a database when I have 2 private ip interfaces.
Steps to reproduce:
1. Server has 2 private interfaces: 10.0.0.100 and 10.10.0.100.
2. Install HP Vertica using: /opt/vertica/sbin/install_vertica --hosts 10.0.0.100 --rpm vertica-7.1.1-0.x86_64.RHEL5.rpm
3. Create database using: admintools -t create_db -s 10.0.0.100 -d testdb --password=testdb
This will fail with the following error messages:
Database with 1 or 2 nodes cannot be k-safe and it may lose data if it crashes
Distributing changes to cluster.
10.0.0.100 OK [vertica][(7, 1, 1)][000][x86_64]
Error: failed to get network profiles
Could not find a suitable network interface: 10.0.0.100
Error: Failed to get network profiles
If I disable the second private address (eg. ifdown eth0:0), then the database creation succeeds.
If in step 2 I used the loopback interface, then step 3's database creation also succeeds.
Is this user error or script error?
Best regards,
Bob.
Sign up
Already have an account? Login
Welcome to the Rocket Forum!
Please log in or register:
Employee Login | Registration Member Login | RegistrationEnter your E-mail address. We'll send you an e-mail with instructions to reset your password.

(((