Skip to main content
Question

How do queries behave after a subcluster is removed?

  • April 2, 2020
  • 1 reply
  • 11 views

kxu
Forum|alt.badge.img

What if a query is running on secondary subcluster and we remove the subcluster? Does the query restart on the primary subcluster?

Sizing and Configuring Vertica in Eon Mode for Different Use Cases
@skeswani @skamat

1 reply

skeswani
Forum|alt.badge.img
  • Participating Frequently
  • April 2, 2020

you can only run a query on a subcluster if you are connected to that subcluster. subclusters are an execution group and are isolated from other subclusters. removing a cluster will terminate all client connections to that subcluster and hence the queries running on those subclusters will fail.