Skip to main content

How much disk space is needed for /opt/vertica/bin

  • May 9, 2018
  • 8 replies
  • 21 views

arvindsugurr

How much disk space is needed for /opt/vertica/bin during installation ?
I dont see it mentioned in any of the documents

8 replies

Jim_Knicely
Forum|alt.badge.img+2
  • Participating Frequently
  • May 9, 2018

Hi,

Hope this helps:

[dbadmin@s18384357 ~]$ du /opt/vertica --summarize -h
11G     /opt/vertica

[dbadmin@s18384357 ~]$ du /opt/vertica/bin --summarize -h
256M    /opt/vertica/bin

arvindsugurr
  • Author
  • New Participant
  • May 9, 2018

thank you any official documentation around this ?


arvindsugurr
  • Author
  • New Participant
  • May 9, 2018

The reason i posted this query is one of the customers is trying to install vertica which fails

Installing Data Repository (Vertica)

./resources/vertica-8.1.0-4.x86_64.RHEL6.rpm located....................[OK]
./resources/vlicense.dat located........................................[OK]
Checking to see if Vertica Installation Package already exists...
Performing a new installation of Vertica...
Preparing... ########################################
Updating / installing...
vertica-8.1.0-4 ########################################
error: unpacking of archive failed on file /opt/vertica/packages/idol/lib/libvertica_idol.so.8.1.0;5af2ee1f: cpio: write failed - Inappropriate ioctl for device
error: vertica-8.1.0-4.x86_64: install failed

Vertica installation package install failed.............................[FAIL]

===============================================================================

Script finished - ./dr_install.sh

[root@deda1x2930 logs]# df -h
Filesystem Size Used Avail Use% Mounted on
/dev/mapper/rootvg-rootlv 1014M 69M 946M 7% /
devtmpfs 16G 0 16G 0% /dev
tmpfs 16G 12K 16G 1% /dev/shm
tmpfs 16G 25M 16G 1% /run
tmpfs 16G 0 16G 0% /sys/fs/cgroup
/dev/mapper/rootvg-usrlv 4.0G 1.3G 2.8G 33% /usr
/dev/sda1 240M 181M 43M 81% /boot
/dev/sdd 2.0T 1.3G 1.9T 1% /CA
/dev/mapper/rootvg-tmpinstlv 1014M 33M 982M 4% /tmp_inst
/dev/mapper/rootvg-homelv 1014M 33M 982M 4% /home
/dev/mapper/rootvg-usrlocallv 253M 40M 214M 16% /usr/local
/dev/mapper/rootvg-tmplv 2.0G 33M 2.0G 2% /tmp
/dev/mapper/rootvg-optlv 1014M 755M 260M 75% /opt
/dev/mapper/rootvg-varlv 2.0G 1.3G 711M 66% /var
/dev/mapper/rootvg-varfactorylv 253M 13M 240M 6% /var/factory
/dev/mapper/rootvg-varspoollv 253M 14M 240M 6% /var/spool
155.250.78.123:/export/dfs/is 6.0T 5.3T 786G 88% /dfs/is
tmpfs 3.2G 0 3.2G 0% /run/user/97884
tmpfs 3.2G 0 3.2G 0% /run/user/98327


Jim_Knicely
Forum|alt.badge.img+2
  • Participating Frequently
  • May 9, 2018

I believe that if it is a space issue, you'd get this error: "cpio: write failed - No space left on device".


arvindsugurr
  • Author
  • New Participant
  • May 9, 2018

Any suggestion on what could be the problem we are able to do SCP of files between the cluster boxes with root user


Jim_Knicely
Forum|alt.badge.img+2
  • Participating Frequently
  • May 10, 2018

A quick Google search shows:

"inappropriate ioctl for device" is the error string for the ENOTTY error. It used to be triggerred primarily by attempts to configure terminal properties (e.g. echo mode) on a file descriptor that was no terminal (but, say, a regular file), hence ENOTTY. ... When stdout is not a terminal this fails with the IOCTL message.

How are they trying to install the Vertica RPM? I'm guessing not from a command line.


arvindsugurr
  • Author
  • New Participant
  • May 16, 2018

Hi Jim,

rpm is first transferred over to other nodes using ssh and then triggered


s_crossman
Forum|alt.badge.img
  • Participating Frequently
  • May 16, 2018

For what it's worth, in normal install the rpm is installed on a host, and then the Vertica install script copies the rpm to the other hosts in the cluster and remotely kicks of install. So if this is the first rpm install on the first host it should have nothing to do with scp or ssh. Have they tried downloading the distrib from the Vertica site and retried? Maybe a corrupted rpm file. You can check the file by copying it to a junk dir and using either:
rpm2cpio filename.rpm | cpio -idmv
or
tar xvf filename.rpm (I think this is newer versions of tar only)

I hope it helps.