I have sessions that are showing as still active and holding memory, via resource_acquisitions and sessions. However, there are no corresponding rows in transactions for these sessions. I have tried using interrupt_statement and close_session many times, but the sessions will not go away. The sessions are all coming in via JDBC connections. The problem is that as more of these sessions accumulate, I end up getting resource allocation errors. I've also tried a force shutdown on the database but that never completes either. So far, the only way I have found to get rid of them is to hard-kill the unix os vertica process itself - which is most definitely not a preferred way of dealing with things.
Is there any other method of force killing a session and getting the resources released?
Thanks,
-Sheila