I recently upgraded Vertica to v23.4. Now I am seeing the following error in my application.
"Failed to connect to xxxxx on host x.x.x.x, port 5433. Reason: FATAL: Session idle for more than 10000 ms. Session Timed Out!
"
I checked vertica.log files and could see the following
"[Session] Set idle timeout for remote host y.y.y.y to 00:00:10" which confirms the idle session for this host is being set as 10 seconds.
In the same logs it is declaring the idle session timeout for the user correctly
2024-05-10 06:10:31.331 Init Session:0x7fbfc8d0a700 @v_vertica_qa_node0001: 00000/7400: Current idle session timeout = 01:00
We have not configured 10 seconds timeout in the user, DB or node level. The idle session timeout configured as default is UNLIMITED and the idle session timeout for this specific user is 1 Hour.
In verticas that are not v23.4, I am not seeing the log line which says "Set idle timeout for remote host ..."
Is this 10 seconds, default value for vertica v23.4 ? Or is this related to the client being used ?
