Skip to main content

Intermittent connection problem with Vertica 8.1.1

  • January 17, 2018
  • 6 replies
  • 9 views

Bernard92
Forum|alt.badge.img+2

Hi all,
I have been asked to investigate a problem with an embedded installation of Vertica 8.1.1 running with the HybridIT products
After a little while , connections to the database become very unpredictable and might fails using a JDBC client or directly on the server

[vertica@hcmvertica ~]$ vsql
vsql: server closed the connection unexpectedly
This probably means the server terminated abnormally
before or while processing the request.

[Vertica]VJDBC IOException while communicating with server: java.io.EOFException.

There's nothing in the vertica.log related to these errors

In admintools , the vertica cluster is considered as DOWN

The only solution is to bounce the vertica server

Any idea ?

Regards
Bernard

6 replies

Jim_Knicely
Forum|alt.badge.img+2
  • Participating Frequently
  • January 17, 2018

Hi,

From my experience, those VSQL/JDBC errors typically mean that the client lost connectivity to the server for some reason (i.e. network timeout / it was closed via the CLOSE_SESSION function).

But you are saying they get the error immediately when typing vsql? And you say admintools says the database is down? If the DB is down, you normally get a different error:

[dbadmin@s18384357 v_sfdc_node0001_catalog]$ admintools -t list_allnodes | grep sfdc
 v_sfdc_node0001               | 74.208.100.58 | DOWN  | vertica-9.0.1.0 | sfdc

[dbadmin@s18384357 v_sfdc_node0001_catalog]$ vsql
vsql: could not connect to server: Connection refused
        Is the server running on host "???" and accepting
        TCP/IP connections on port 5433?

praveshbhardwaj
Forum|alt.badge.img+1
  • Participating Frequently
  • January 18, 2018

Have you tried connecting using IP (vsql -h)? JDBC client connects using public IP?

At the time when admintools reports DB down, can you execute queries from any of the still active connections?


Jim_Knicely
Forum|alt.badge.img+2
  • Participating Frequently
  • January 18, 2018

Hmm. @praveshbhardwaj,that's a good point about private vs. public IPs. If they do have separate networks @Bernard92 can try vsql -h [private_ip] vs. vsql -h [public_ip]. Do you get the same error?

Anyway, I would think those "connected" clients will report the same error (server closed the connection unexpectedly) when they try to run a query as I bet they aren't really connected anymore. Note VSQL used in interactive mode will try to reconnect after getting the error.

Other possibilities:

Is spread not up on each node?

ps -ef | grep [^]]spread

What does dbadmin say about the node status for each node? DOWN or UNKNOWN?

admintools -t list_allnodes | grep <<dbname>>


praveshbhardwaj
Forum|alt.badge.img+1
  • Participating Frequently
  • January 18, 2018

If Vertica process actually remains running and admintools reports DB as DOWN, I would look for IP configuration. Check admintools and spread config to see what interface both are configured on.

As Jim suggested, vsql -h on both public and private IP should suggest something. Since you said embedded installation, I assume it's single node installation, so ruling out load balancer.


Bernard92
Forum|alt.badge.img+2
  • Author
  • Participating Frequently
  • January 18, 2018

yes , this is a embedded installation with a single node , and only 1 public IP
I'll try next time to connect using the -h option
The remaining active sessions are batch sessions run by the HybridIT containers , so we don't really have control on them
spread was still up when we had the last hang


Bernard92
Forum|alt.badge.img+2
  • Author
  • Participating Frequently
  • January 19, 2018

The ITOM/HybridIT people have finally fixed the problem , it seems the Vertica installation needs to be setup with SSL enabled and configured.
Any idea why it would generate these intermittent problem ?
I am a bit puzzled