Skip to main content

Invalid frontend message type 80

  • June 7, 2018
  • 2 replies
  • 16 views

sreeblr
Forum|alt.badge.img+2

we are getting this messages in error table. Any idea on what could be the error

2 replies

sreeblr
Forum|alt.badge.img+2
  • Author
  • Participating Frequently
  • June 7, 2018

from vertica.log 2018-06-06 08:21:46.385 Init Session:7f9afdffa700
@v_medicaid_node0001: {SessionRun} 08V01/3667: Invalid frontend message type 80
LOCATION: ??, /scratch_a/release/svrtar17748/vbuild/vertica/MsgProtocol/Server.cpp:443


twall
Forum|alt.badge.img
  • Participating Frequently
  • June 7, 2018

Hi sreeblr

It is a little difficult to tell what is going on from the small log snippet you've provided. In general the database clients & servers speak in terms of well-formed protocol messages, and the error here says the client sent an invalid one. This error could happen at any point in time during any operation, and if it ever does it is probably a bug in the client. If you are using one of vertica's standard clients then you should report this issue to support.

The message may also be coming from some other system trying to talk to vertica. In the past for example, we have seen load balancers send packets to 5433 as a health check, and those sort of tools do not honor the normal client-server protocol and would cause this sort of problem. If so, it may be safe to ignore them if you are ok with the tool doing that.