Skip to main content
Question

Issue with starting vertica DB

  • June 4, 2024
  • 5 replies
  • 8 views

vaishnavav99
Forum|alt.badge.img+1

Issue : Could not start vertica db. The db fails with error message host report: Database path already in use: /data/vertica//

Scenario : We created a new ubuntu linux vm and configured and installed vertica.Database configured. We then try to detach the disk and reattach the disk from the previous vm and then try to start the database.

Any hint on figuring this out would be helpful

5 replies

Bryan_H
Forum|alt.badge.img+2
  • Participating Frequently
  • June 4, 2024

DId you also copy the admintools config from /opt/vertica/config on the old VM? That is necessary to point to the data, catalog, and other paths as well as define IP's. You may also need to re-IP with admintools if the node IP's changed.


vaishnavav99
Forum|alt.badge.img+1
  • Author
  • Participating Frequently
  • June 5, 2024

@Bryan_H As suggested we copied the configs corresponding to admintools and the db was up, however i am now unable to connect to the database. While trying to connect we now get Unable to connect to DB client on any host. We are unable to stop the database through admintools and commandline. Nor can i run the re-IP with admintools since the cluster and db is up.


SruthiA
Forum|alt.badge.img+1
  • Participating Frequently
  • June 5, 2024

could you please share the output of the following. does it show the right IP's for the corresponding vm's?

admintools -t list_allnodes


vaishnavav99
Forum|alt.badge.img+1
  • Author
  • Participating Frequently
  • June 6, 2024

@SruthiA It gives IP of the old VM


SruthiA
Forum|alt.badge.img+1
  • Participating Frequently
  • June 6, 2024

it means that reip was not successful. we may need to review the issue via call. please open a support case.