This article provides information on why insert query is failing when executed through client driver.
Environment:
Vertica analytics Database: v24.4.x
Situation:
Error while executing insert statement using client driver on Vertica.
Cause:
Its failing due to client side TLS error. Query is failing because client disconnections due to open SSL error.
08V01/9334: ssize_t TLS::write(Session::Port*, void*, size_t): TLS error: error code: 0A00010F, location SSL routines:ssl3_write_bytes ssl/record/rec_layer_s3.c:389, reason [bad length]
08006/2907: Could not send data to client: No such file or directory
<FATAL> @<node_name>: 08006/2607: Client has disconnected
Find resolution on support portal