An operating system restart caused an abrupt shutdown of the database, which led to corruption of Node 2’s catalog and data. This corruption prevented Node 2 from starting. After multiple recovery attempts failed, a scratch recovery was performed by removing the data and catalog directories. This process successfully restored Node 2, and the cluster is now healthy.
Environment
- Product: Vertica Database
- Version: all
Problem
Node 2 failed to start and returned the error:
Unable to read database catalogs - cannot start database.
Find complete article on support portal