This knowledge base article addresses a situation where some views are not accessible after creating a new user The article explains the cause of the errors, provides a resolution to address the issue, and offers insight into potential preventative measures.
Environment:
Vertica 11.0.2-8
Situation:
After creating a user, it cannot access the views that were granted access to.
Cause:
Missing default role to the user.