While trying to revive the database using vcluster, the command throws below error - Error happened during executing vertica-download-file. Stdout: . Stderr:Error happens when copying file from s3://vdb-fut/metadata/bop/cluster_config.json to /tmp/curr_config.json. Error code: 16779814. Error message: Could not copy file [s3://vdb-fut/metadata/bop/cluster_config.json] to [/tmp/curr_config.json]: The specified bucket does not exist. Details: . Return code: 1. Complete error info: exit status 1
Environment
Vertica Analytics Database: v25.x and higher
Situation
While trying to revive the database using vcluster, the command fails and the node_management_agent.log contains below log -
2025/10/07 18:52:52 [Endpoint call]: Vertica download file
2025/10/07 18:52:52 [Info]: SourceFilePath = s3://s3-folder-home/metadata/jack/cluster_config.json
2025/10/07 18:52:52 [Info]: DestFilePath = /tmp/curr_config.json
2025/10/07 18:52:52 [Info]: CatalogPath =
2025/10/07 18:52:52 [Info]: Parameters = ******
2025/10/07 18:52:52 [Info]: AWSAccessKeyID = ******
2025/10/07 18:52:52 [Info]: AWSSecretAccessKey = ******
2025/10/07 18:52:52 [Info]: [Vertica Download File]: vertica-download-file command: /opt/vertica/bin/vertica-download-file--source-file s3://s3-folder-home/metadata/jack/cluster_config.json --destination-file /tmp/curr_config.json --catalogpath --logdir /opt/vertica/log
2025/10/07 18:54:58 [Error]: Error happened during executing vertica-download-file. Stdout: . Stderr:Error happens when copying file from s3://s3-folder-home/metadata/jack/cluster_config.json to /tmp/curr_config.json. Error code: 16779814. Error message: Could not copy file [s3://s3-folder-home/metadata/jack/cluster_config.json] to [/tmp/curr_config.json]: The specified bucket does not exist. Details: . Return code: 1. Complete error info: exit status 1
Trending Articles
- The event with ID 'xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx' does not exist or is not accessible by the user
- List of latest available hotfixes for supported Content Manager versions
- Save mail as a PDF file fails after updating Windows.
- Kerberos Authentication Fails After Upgrade to Access Manager 5.1.1.1 Due to Disabled RC4 Support
- Support Matrices for Operations Center products
