vbr backup in vertica fails with below error - An error occurred (404) when calling the HeadObject operation: Not Found.: returncode=None.
Environment
Vertica Analytics Database: v25.2
Situation
While running the vbr backup, the backup would consistently fail with below error -
On host 127.0.0.1: Error accessing remote storage: When copying file 02ec244409d6cf9c58b3b053b81c9bd500b00000178df6a0/02ec244409d6cf9c58b3b053b81c9bd500b00000178df6a0.tar (bucket s3://vertica-communal-bucket-886503275546-test/test_database/metadata/VerticaDB/Libraries/) to Objects/02ec244409d6cf9c58b3b053b81c9bd500b00000178df6a0/02ec244409d6cf9c58b3b053b81c9bd500b00000178df6a0.tar (bucket vertica-new-backup1): An error occurred (404) when calling the HeadObject operation: Not Found.: returncode=None.
Hint: VBR detects the Vertica session that holding reference count on storage got killed in the middle of the vbr task, storage files could be deleted by some other processes, please rerun this vbr task once again.
Backup FAILED.
Find complete article on support portal