Skip to main content

Library with name 'KafkaLib' does not exist

  • November 22, 2015
  • 4 replies
  • 26 views

Viacheslav

Hello,

I have comminity edition Vertica 7.2 and I'm trying to consume messages from kafka into flex table. 

I've created scheduler with default settings but when I edit scheduler adding brokers info

./vkconfig scheduler --edit --brokers hostname:9092 --operator dbadmin --username dbadmin

 

I'm getting 

java.sql.SQLSyntaxErrorException: [Vertica][VJDBC](3862) ROLLBACK: Library with name 'KafkaLib' does not exist

 

Please help me to fix it.

4 replies

Ravlio
  • Participating Frequently
  • November 23, 2015

Strange that KafkaLib installs automatically as you installed Vertica 7.2 update, at least in my case. Anyway you can try to install Kafka UDx manually by running this commaind on each node (under dbadmin):

 

/opt/vertica/bin/vsql -a -f /opt/vertica/packages/kafka/ddl/install.sql

 

Before doing this check that you really do not have Kafka already installed:

 

select * from USER_LIBRARIES

When installed you will see something like this:

 

public      | KafkaLib       | 45035997964086902 | HP Vertica | 45035996273704962 | KafkaLib_026497d68bc91ce792925b04e775630c00a0000064c12e76.so       | 070548f9e55b09248454dabe6a4d0597 | 7.2.0       | 174832   | 174832        | 7.2.0       | 7.2.0           | http://www.vertica.com/ | Kafka streaming load and export

 


Viacheslav
  • Author
  • Participating Frequently
  • November 25, 2015

Thank you! That's solved. What kafka version you use? I have 0.8.2.

I'll try to config and post you update.


Viacheslav
  • Author
  • Participating Frequently
  • November 25, 2015

Althought error has gone I can't see any rows in 

USER_LIBRARIES

Viacheslav
  • Author
  • Participating Frequently
  • November 25, 2015

One more interesting thing is that vertica works for a while (about 30min) to consume messages but after that I can't login in via vsql

 

vsql --username dbadmin

vsql: could not connect to server: Connection refused

Is the server running on host "???" and accepting

TCP/IP connections on port 5433?

 

netstat -apn | grep 5433

(Not all processes could be identified, non-owned process info

will not be shown, you would have to be root to see it all.)

tcp6       1      0 127.0.0.1:48567         127.0.0.1:5433          CLOSE_WAIT  -