Skip to main content

License expired

  • July 11, 2017
  • 4 replies
  • 16 views

nitinkr55

Can anyone tell me what was the impact of vertica license expiry on cluster :)

4 replies

Lokesh_1
Forum|alt.badge.img
  • Participating Frequently
  • July 11, 2017

It is keep running until you cross grace period as well. As far as I know, once grace period is over, DB should not start once it goes down.


RaghavA
Forum|alt.badge.img
  • Participating Frequently
  • July 11, 2017

Hi Lokesh,

Do you know how to tackle a problem when get_compliance_status() shows that everything is OK but still you receive error message "License issue: No Vertica license is installed" in error_messages table?

I am running on v7.2.3.9

Regards,
Raghav Agrawal


Jim_Knicely
Forum|alt.badge.img+2
  • Participating Frequently
  • July 11, 2017

From my experience, a database will come up (if it is down) even after the license has expired (including the grace period). However, they will get error messages indicating they need to get a new license when they attempt to issue DDL and DML against their data... Also, they will no longer be able to select, update, insert or delete data.

Example:

I started a database I have where the license expired a while ago:

dbadmin=> select now(), start_time from databases;
              now              |          start_time
-------------------------------+------------------------------
 2017-07-11 10:14:01.279826-04 | 2017-07-11 10:09:54.00764-04
(1 row)

dbadmin=> select get_compliance_status();
                                                                                                                      get_compliance_status                                                        
------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
 Raw Data Size: 0.00TB +/- 0.00TB
 License Size : 10.00TB
 Utilization  : 0%
 Audit Time   : 1999-12-31 19:00:00-05
 Compliance Status : The database is in compliance with respect to raw data size.

 License End Date: 2017-1-11
 Days Past Expiration: 180.38
(1 row)

dbadmin=> select display_license();
                    display_license
-------------------------------------------------------
 Hewlett-Packard Company
2016-12-12
2017-1-11
30
10TB

(1 row)

dbadmin=> create table mytest (c1 int);
WARNING 3863:  License issue: Vertica license is expired
HINT:  Visit http://www.vertica.com/about/contact-us
CREATE TABLE

dbadmin=> insert into mytest values (1);
ERROR 5517:  Your Vertica license is invalid or has expired
HINT:  To obtain a license please visit http://www.vertica.com/about/contact-us

dbadmin=> select * from mytest;
ERROR 5517:  Your Vertica license is invalid or has expired
HINT:  To obtain a license please visit http://www.vertica.com/about/contact-us

Note that although I could create the table, but I could not insert into it or select from it.

See:
https://my.vertica.com/docs/8.1.x/HTML/index.htm#Authoring/AdministratorsGuide/Licensing/ManagingLicenseWarningsAndLimits.htm

It states "After the grace period expires, Vertica stops processing queries."


Lokesh_1
Forum|alt.badge.img
  • Participating Frequently
  • July 12, 2017

@Jim_Knicely : Thanks for correcting me.

@RaghavA : Best way to handle it, is to raise case with vertical support who should raise bug for same, if no explanation for it.

Just for test purpose, could you try installing license one more time and check if same goes away?