Skip to main content

Management console 500 Server Error

  • June 28, 2016
  • 2 replies
  • 11 views

Kondor
  • Participating Frequently

Hi all,

 

I noticed an annoying problem with management console, namely after I played around with the settings of the database, now I'm not able to reach the site.

Always after I try to see the page under https://myIP:5450/webui/databases/104/config I got the white page in frontend and 500 error in the firebug. All other pages/links are working as expected.

 

Could someone give me the hint where can I check some extended errors related to the GUI?

 

Thanks in advance-

 

Konrad

 

2 replies

Rahul_Choudhary
Forum|alt.badge.img
  • Participating Frequently
  • June 29, 2016

Hi

 

Looks to be a known issue.

 

Can you write below mentioned parameter in /etc/init.d/vertica-consoled and change the locale?


export LANG=en_US.UTF8

 

After setting the same I believe this issue should be resolved.

 

Thanks

Rahul Choudhary


Kondor
  • Author
  • Participating Frequently
  • June 29, 2016

Hi,

 

thanks for your reply, my locale settings looks IMHO ok

 

[mcadmin@vertica_host_node_1 root]$ locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"

I don't get which parameter in  /etc/init.d/vertica-consoled you mean exactly. There is rather no parameter in this file :)

 

And in the meantime I've solved it in straightforward way. I've removed the database in MC and added it once again. After that step the settings are available again.