Skip to main content

MC "Overview page"

  • February 5, 2016
  • 23 replies
  • 60 views

_AG_
Forum|alt.badge.img
  • Participating Frequently

Hi,

I'm very new to Vertica. I just finished installing it from scratch in a 2 node servers (Community Edition).

When I try to access the Overview page in the Management Console, I see this screen, where the options are not visible (but they're there if I tamper the css of the page.

 

OverviewPage.PNG

 

Everything appears to be right on the database side (I can use it without issues), but I'm affraid perhaps I missed something here in the MC side.

Cluster.PNG

Any help will be appreciated.

 

23 replies

SruthiA
Forum|alt.badge.img+1
  • Participating Frequently
  • February 5, 2016

Hi,

 

        Did you check if there is any firewall blocking communications?? Can you share me the screenshot as what is visible when you login into MC

 

 

Thank you,

 Sruthi


_AG_
Forum|alt.badge.img
  • Author
  • Participating Frequently
  • February 5, 2016

Hi SruthiA

I checked and no firewall in the middle. I hope you're talking about this screens:

Screen 1.PNG

 

 

Screen 2.PNG


SruthiA
Forum|alt.badge.img+1
  • Participating Frequently
  • February 5, 2016

Hi,

 

     Yes. I am talking about those screens. As soon as you login for the first time , were you able to see configuration wizard??

 

 

Sruthi


_AG_
Forum|alt.badge.img
  • Author
  • Participating Frequently
  • February 5, 2016

Nop. I didn't.

I imported the Cluster & DB from the "Provision Databases" link in the front page.


SruthiA
Forum|alt.badge.img+1
  • Participating Frequently
  • February 5, 2016

Hi,

 

 

        It might be that MC has not installed properly. Can you  uninstall and try installing it again? Did you check for rprerequisistes? Are all satisfied??

 

 

http://my.vertica.com/docs/7.2.x/HTML/index.htm#Authoring/InstallationGuide/InstallingMC/BeforeYouInstallManagementConsole.htm%3FTocPath%3DInstalling%2520Vertica%7CInstalling%2520Vertica%7CInstalling%2520and%2520Configuring%2520Management%2520Console%7C_____1

 

 

Thank you,

 Sruthi


_AG_
Forum|alt.badge.img
  • Author
  • Participating Frequently
  • February 5, 2016

I followed all the steps in the guide.

But I'll do them again and let you know.

Thanks


_AG_
Forum|alt.badge.img
  • Author
  • Participating Frequently
  • February 5, 2016

Hi Shutri

I uninstalled MC, deleted /opt/vconsole folder and started from scratch in both nodes.

I did used the config wizard once I logged in for the first time to set up MC, imported the cluster, but the Overview page stays the same as previous screenshots...

 

Any idea?


_AG_
Forum|alt.badge.img
  • Author
  • Participating Frequently
  • February 5, 2016

BTW, when I try to access the Design option, I receive "String index out of range: 1" as a result


SruthiA
Forum|alt.badge.img+1
  • Participating Frequently
  • February 5, 2016

Hi,

 

   Can you find the mconsole.log and share it??

 

 

 

Thank you,

 Sruthi


SruthiA
Forum|alt.badge.img+1
  • Participating Frequently
  • February 5, 2016

Could you please share me the vertica version,operating system mc version you are using


_AG_
Forum|alt.badge.img
  • Author
  • Participating Frequently
  • February 5, 2016

I'm attaching the mconsole.log

 

As for the versions, vertica and MC are 7.2.1 for Debian.

I'm running an Ubuntu 15.10 server on every node w/4 cores (i7 3.6GHz) and 13GB RAM each in a VMWare virtual machine


SruthiA
Forum|alt.badge.img+1
  • Participating Frequently
  • February 5, 2016

Hi,

 

   I checked the log and looks like it is unable to connect to 192.168.2.17 Can you check??. What is the value of  LANG enviroment variable?

 

04 Feb 2016 21:11:06,709 [main] VCConfigRegistrator ERROR - Cannot find enough parameters for creating audit connection pool.
04 Feb 2016 21:15:27,511 [qtp396899735-68 - /webui/buildinfo?1454638527093] HomeController ERROR - getMCBuildInfo>> transferObj.success==false
04 Feb 2016 21:15:38,846 [qtp396899735-79 - /webui/buildinfo?1454638538553] HomeController ERROR - getMCBuildInfo>> transferObj.success==false
04 Feb 2016 21:21:05,096 [qtp396899735-78 - /webui/buildinfo?1454638865040] HomeController ERROR - getMCBuildInfo>> transferObj.success==false
04 Feb 2016 21:22:02,729 [qtp396899735-78 - /webui/buildinfo?1454638922530] HomeController ERROR - getMCBuildInfo>> transferObj.success==false
04 Feb 2016 21:25:25,245 [qtp396899735-83 - /webui/buildinfo?1454639125184] HomeController ERROR - getMCBuildInfo>> transferObj.success==false
04 Feb 2016 21:27:08,970 [qtp396899735-82 - /webui/buildinfo?1454639228892] HomeController ERROR - getMCBuildInfo>> transferObj.success==false
04 Feb 2016 21:28:15,145 [qtp396899735-78 - /webui/buildinfo?1454639295106] HomeController ERROR - getMCBuildInfo>> transferObj.success==false
04 Feb 2016 21:33:51,008 [Thread-4] WorkQueue ERROR - kickOffPollingTask>> Exception while polling: null
04 Feb 2016 21:33:51,009 [Thread-4] WorkQueue ERROR - java.lang.NullPointerException
05 Feb 2016 09:44:29,668 [main] AgentCommands ERROR - Error connecting to 192.168.2.17. Exception:No route to host
05 Feb 2016 09:44:29,843 [main] WebappDbInitContextListener ERROR - Could not establish a connection with the agent
05 Feb 2016 09:44:41,668 [main] AgentCommands ERROR - Error connecting to 192.168.2.17. Exception:No route to host
05 Feb 2016 09:44:41,672 [main] AgentCommands ERROR - executeCommandWithRetryWithinCluster>> Could not connect to any agent in the cluster!
05 Feb 2016 09:44:41,931 [main] AgentConnectionServiceImpl ERROR - createWebHook>> Error response from agent. transferObject: TransferObject [success=false, messageCode=0, messageStr=Could not connect any agent in the cluster. Please contact your administrator, obj=null]
05 Feb 2016 09:44:53,669 [main] AgentCommands ERROR - Error connecting to 192.168.2.17. Exception:No route to host
05 Feb 2016 09:44:53,691 [main] AgentCommands ERROR - executeCommandWithRetryWithinCluster>> Could not connect to any agent in the cluster!
05 Feb 2016 09:44:53,762 [main] VCConfigRegistrator ERROR - Cannot find enough parameters for creating audit connection pool.

 

 

Thank you,

 Sruthi


SruthiA
Forum|alt.badge.img+1
  • Participating Frequently
  • February 5, 2016

where did you install MC? did you install it on one of the nodes of the cluster??

 

 

Sruthi


_AG_
Forum|alt.badge.img
  • Author
  • Participating Frequently
  • February 5, 2016

Hi,

The value of LANG=en_US.UTF-8

 

And yes, I installed MC in one of the nodes (actually on both): 192.168.2.8 and 192.168.2.17


SruthiA
Forum|alt.badge.img+1
  • Participating Frequently
  • February 5, 2016

Hi,

 

   Please uninstall on both of them and just install on one node

 

 

Sruthi


alk
  • New Participant
  • February 9, 2016

Hi, I've same problem: Overview page is blank in MC. Also, Resource Pool is blank and I can't create new because it give me error without information.

Uninstall, remove and install again, but error persist.

Database and MC version 7.2.1-0

SO: Debian

Install only one node.

 

Resource Pool is correct in DB because I do in vsql: 

VMart= > SELECT * FROM V_CATALOG.RESOURCE_POOL_DEFAULTS;

RESOURCE_POOL_DEFAULTS has 10 rows. I only have VMart example database.

 

In mconsole.log:

09 feb 2016 17:15:09,139 [org.springframework.scheduling.quartz.SchedulerFactoryBean#0_Worker-10] ThresholdJob WARN - Warnning when checking Resource Pool Availible. Message: null
09 feb 2016 17:15:35,565 [qtp1812112452-270 - /webui/buildinfo?1455034526536] SystemInfoServiceImpl INFO - Is this a Debian system? true
09 feb 2016 17:15:35,565 [qtp1812112452-270 - /webui/buildinfo?1455034526536] VuiUtils INFO - executeCommand>> command: dpkg -p vertica-console | grep Version
09 feb 2016 17:15:35,599 [qtp1812112452-270 - /webui/buildinfo?1455034526536] SystemInfoServiceImpl INFO - getBuildInfo>> commandOutput:
09 feb 2016 17:15:35,599 [qtp1812112452-270 - /webui/buildinfo?1455034526536] HomeController ERROR - getMCBuildInfo>> transferObj.success==false

 

Always when "ERROR - getMCBuildInfo" is both "dpkg -p vertica-console | grep Version". This command is null, if change -p with -s works.

Parameter -p work with some package, but not with vertica and vertica-console.

 

Do you think is package bug? Or does anyone have a solution?

 

 


_AG_
Forum|alt.badge.img
  • Author
  • Participating Frequently
  • February 9, 2016

I've tried everything, created a new node, installed everything from scratch, followed step by step the Installation guides, and still have the same problem.

 

I don't have the chance to run Linux+Vértica outside a VM (VM Workstation 12, latest update).

 

Hope somebody can help us with this problem.

 

 


Chris_S
Forum|alt.badge.img
  • Participating Frequently
  • February 10, 2016

Hi _AG_, alk, 

 

What browsers are you using when seeing the blank overview page? Are you able to try a different browser?

Can you let me know if there are any browser-console errors when seeing the blank MC Overview page? If you are unsure how to do that, I can provide steps once I know the browser.

 

Thanks,

Chris


SruthiA
Forum|alt.badge.img+1
  • Participating Frequently
  • February 10, 2016

HI,

 

   What is the Operating system you are using??

 

 

Sruthi


SruthiA
Forum|alt.badge.img+1
  • Participating Frequently
  • February 10, 2016

Hi,

 

   Is the LANG value same across all nodes in the cluster? What is the value of LC_ALL environmental variable?

 

 

Thank you,

Sruthi


_AG_
Forum|alt.badge.img
  • Author
  • Participating Frequently
  • February 10, 2016

In my case, I'm using Ubuntu Server 15.10

I tried every browser I know from different platforms (Win, MAC & Linux).

 

There are no errors in the console.


SruthiA
Forum|alt.badge.img+1
  • Participating Frequently
  • February 10, 2016

Hi,

 

 

          We do not support Ubuntu 15.10. THe latest version that we support in ubuntu is 14.04 LTS

 

Please visit the following URL for the list of supported operating systems for Management Console

 

http://my.vertica.com/docs/7.2.x/HTML/index.htm#Authoring/SupportedPlatforms/MCandServer.htm%3FTocPath%3DVertica%25207.2.x%2520Supported%2520Platforms%7C_____1

 

 

It might be the reason for MC page not displaying properly. We also found that it was not showing configuration wizard when you first logged in

 

 

Sruthi


alk
  • New Participant
  • February 11, 2016

Solved.

In my case had Debian 8 and not works. 

I'd installed Debian 7.7 (recommended for HPE) and works. New versions Debian and Ubuntu don't works.

I tried install over Debian 8 because in DOC I read "All versions starting at 7.0 up to" and I belived that install was possible but some things are wrong.

 

Thanks for your time.